Closed Bug 11082 Opened 21 years ago Closed 20 years ago

Unable to input consecutively 8bit high ascii in header/body (focus problem)

Categories

(MailNews Core :: Composition, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: marina, Assigned: buster)

References

Details

Steps to reproduce:
-open New Mail Composition windows;
-in the Subject field try to input a raw of high ascii using ALT+ )224 ..etc
//note : the first char is in there but there is no unput if you continue to
hold ALT
-same is happening with the mail body
******observed with today 08-02-99 windows build
Is this a messenger specific problem or reproducable in the editors?
i guess we have to change the component from Internationalization/Mail to Editor
because i'm having the same problem there.
Assignee: nhotta → tague
This is a generic problem of input. Reassigning to tague.
Assignee: tague → ducarroz
Component: Internationalization → Composition
Assignee: ducarroz → buster
reassigning to ender
actually, I think this is because the Alt keyUp sends focus to the File menu.
On windows, it shouldn't if it was used in conjunction with a character entry.
I think this is a generic key processing problem, not an editor problem.  hyatt,
joki, tague, what do you think?
Probably windows only, sujay or marina, can you verify that please?
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed.  Pull layout/xul/base/src/nsMenuBarListener.cpp.
Status: RESOLVED → REOPENED
** Checked with 8/13/99 Win32 build **

This is not really fixed.
In the header field, the focus is lost after 1 character input.
In the body text field, the focus is lost after 2 characters input.
We then have to click into these fields to start inputting again.
Resolution: FIXED → ---
Blocks: 12907
Summary: Unable to input consequitively 8bit high ascii in the header and body → Unable to input consecutively 8bit high ascii in header/body (focus problem)
adding (focus problem) to the summary since that seems to most accurately
describe the current problem.
Kat -- can you check up on this and see if this is still an issue in a more
current build?

Steve -- if this is still an open issue -- we will need to set a milestone date
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
** Checked with 10/27/99 Win32 build (1999102708) **

The remaining problem as described in my 8/13/99 note, i.e.
that of lost focus after one or two character input no longer
exists with the above build in any field of the Mail Compose
Window. Neither does it seem to exist in the Composer window.
Now I can type Latin 1 accented characters to my heart's content.

Marking this bug fixed, and then verified as fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.