Firefox stops refreshing the UI

RESOLVED DUPLICATE of bug 1067470

Status

()

RESOLVED DUPLICATE of bug 1067470
4 years ago
3 years ago

People

(Reporter: csaba, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

Occurs randomly, sometimes after few hours sometimes after 2 minutes


Actual results:

Firefox stops refreshing the main window. I can see the title changing on the taskbar when I click on tabs, but the whole main window looks frozen. Restarting firefox is the only solution.


Expected results:

I guess it shouldn't behave like this.
(Reporter)

Comment 1

4 years ago
I ran a procdump -e 1 -f "" <pid>. The problem started at 12:38:06

[12:35:46] Exception: 406D1388
[12:36:06] Exception: 406D1388
[12:36:06] Exception: 406D1388
[12:36:06] Exception: 406D1388
[12:36:07] Exception: 406D1388
[12:36:10] Exception: 406D1388
[12:36:10] Exception: 406D1388
[12:36:11] Exception: 406D1388
[12:36:11] Exception: 406D1388
[12:37:06] Exception: 406D1388
[12:37:10] Exception: 406D1388
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.msc
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
[12:38:06] Exception: E06D7363.?AV_com_error@@
...

The call stacks for the exceptions are below.

ChildEBP RetAddr  
0d3fe42c 774b22b4 KERNELBASE!RaiseException+0x48
0d3fe464 6e9aff89 msvcrt!_CxxThrowException+0x59
0d3fe5c0 6e95f492 d3d11!CShaderResourceView::CLS::FinalConstruct+0x50aee
0d3fe5d0 6e95f232 d3d11!TCLSWrappers<CShaderResourceView>::CLSFinalConstructFn+0x13
0d3fedd4 6e95a4fd d3d11!CDevice::CreateLayeredChild+0x46e
0d3fedf4 6e95be6e d3d11!CBridgeImpl<ID3D11LayeredDevice,ID3D11LayeredDevice,CLayeredObject<CDevice> >::CreateLayeredChild+0x20
0d3fee30 6e95bd9d d3d11!NDXGI::CDeviceChild<IDXGIResource1,IDXGISwapChainInternal>::FinalConstruct+0x2d
0d3feee0 6e95a15c d3d11!NDXGI::CDevice::CreateLayeredChild+0x133
0d3feff4 6e95f85b d3d11!NOutermost::CDevice::CreateLayeredChild+0x1e1
0d3ff088 6e95fb08 d3d11!CDevice::CreateShaderResourceView_Worker+0xf2
0d3ff0a0 6188dab8 d3d11!CDevice::CreateShaderResourceView+0x1b
0d3ff174 6098beab xul!mozilla::layers::CompositorD3D11::DrawQuad+0x2b1 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\d3d11\compositord3d11.cpp @ 649]
0d3ff3c4 60988865 xul!mozilla::layers::ContentHostBase::Composite+0x70b [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\contenthost.cpp @ 178]
0d3ff464 6098fa8e xul!mozilla::layers::ThebesLayerComposite::RenderLayer+0x205 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\thebeslayercomposite.cpp @ 155]
0d3ff504 6099a732 xul!mozilla::layers::RenderLayers<mozilla::layers::ContainerLayerComposite>+0xee [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\containerlayercomposite.cpp @ 425]
0d3ff5c4 6099a809 xul!mozilla::layers::ContainerRender<mozilla::layers::ContainerLayerComposite>+0x42 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\containerlayercomposite.cpp @ 552]
0d3ff5cc 6099532e xul!mozilla::layers::ContainerLayerComposite::RenderLayer+0x14 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\containerlayercomposite.cpp @ 617]
0d3ff680 6099b84c xul!mozilla::layers::LayerManagerComposite::Render+0x31e [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\layermanagercomposite.cpp @ 497]
0d3ff6f4 609ca982 xul!mozilla::layers::LayerManagerComposite::EndTransaction+0x11c [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\layermanagercomposite.cpp @ 257]
0d3ff704 609a53a6 xul!mozilla::layers::LayerManagerComposite::EndEmptyTransaction+0x13 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\layermanagercomposite.cpp @ 207]
0d3ff738 6082e382 xul!mozilla::layers::CompositorParent::CompositeToTarget+0x1a6 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\ipc\compositorparent.cpp @ 695]
0d3ff748 60b8d0de xul!mozilla::layers::CompositorParent::CompositeCallback+0x12 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\ipc\compositorparent.cpp @ 630]
0d3ff754 60b8d9f3 xul!MessageLoop::RunTask+0x13 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 363]
0d3ff75c 60b8df03 xul!MessageLoop::DeferOrRunPendingTask+0x2e [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 373]
0d3ff78c 60b8534f xul!MessageLoop::DoWork+0x61 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 448]
0d3ff79c 60b84b3e xul!base::MessagePumpForUI::DoRunLoop+0x1f [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_pump_win.cc @ 216]
0d3ff7bc 60b84f39 xul!base::MessagePumpWin::RunWithDispatcher+0x3c [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_pump_win.cc @ 56]
0d3ff7c8 60b8d455 xul!base::MessagePumpWin::Run+0xb [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_pump_win.h @ 78]
0d3ff800 60b8d509 xul!MessageLoop::RunHandler+0x51 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 228]
0d3ff820 60b8fe1e xul!MessageLoop::Run+0x19 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 202]
0d3ff90c 60b856d7 xul!base::Thread::ThreadMain+0xa4 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\thread.cc @ 171]
0d3ff910 776c919f xul!`anonymous namespace'::ThreadFunc+0x9 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\platform_thread_win.cc @ 27]
0d3ff91c 77cb0bbb kernel32!BaseThreadInitThunk+0xe
0d3ff960 77cb0b91 ntdll!__RtlUserThreadStart+0x20
0d3ff970 00000000 ntdll!_RtlUserThreadStart+0x1b



ChildEBP RetAddr  
0d3feac0 774b22b4 KERNELBASE!RaiseException+0x48
0d3feaf8 6e9ae5f2 msvcrt!_CxxThrowException+0x59
0d3ff4f4 6e99512c d3d11!CDevice::OpenSharedResourceInternal_Worker+0x4e2e2
0d3ff514 61689101 d3d11!CDevice::OpenSharedResource+0x1e
0d3ff570 6168918c xul!mozilla::layers::DXGITextureHostD3D11::OpenSharedHandle+0x45 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\d3d11\textured3d11.cpp @ 329]
0d3ff580 616a111c xul!mozilla::layers::DXGITextureHostD3D11::DXGITextureHostD3D11+0x3f [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\d3d11\textured3d11.cpp @ 317]
0d3ff5a8 61231061 xul!mozilla::layers::CreateTextureHostD3D11+0x6b [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\d3d11\textured3d11.cpp @ 147]
0d3ff5c4 60840e4f xul!mozilla::layers::TextureHost::Create+0x9f01bd [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\texturehost.cpp @ 210]
0d3ff5dc 60840e12 xul!mozilla::layers::TextureParent::Init+0x1f [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\texturehost.cpp @ 760]
0d3ff5f4 60840dac xul!mozilla::layers::TextureHost::CreateIPDLActor+0x51 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\composite\texturehost.cpp @ 115]
0d3ff604 60c23b12 xul!mozilla::layers::LayerTransactionParent::AllocPTextureParent+0x1b [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\gfx\layers\ipc\layertransactionparent.cpp @ 793]
0d3ff6a0 60bd919c xul!mozilla::layers::PLayerTransactionParent::OnMessageReceived+0x2a7 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\obj-firefox\ipc\ipdl\playertransactionparent.cpp @ 407]
0d3ff6e0 60b96c7e xul!mozilla::layers::PCompositorParent::OnMessageReceived+0x43 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\obj-firefox\ipc\ipdl\pcompositorparent.cpp @ 416]
0d3ff6f4 60b98bef xul!mozilla::ipc::MessageChannel::DispatchAsyncMessage+0x40 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\glue\messagechannel.cpp @ 1167]
0d3ff704 60b99549 xul!mozilla::ipc::MessageChannel::DispatchMessageW+0x61 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\glue\messagechannel.cpp @ 1077]
0d3ff748 60b8d0de xul!mozilla::ipc::MessageChannel::OnMaybeDequeueOne+0xda [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\glue\messagechannel.cpp @ 1061]
0d3ff754 60b8d9f3 xul!MessageLoop::RunTask+0x13 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 363]
0d3ff75c 60b8df03 xul!MessageLoop::DeferOrRunPendingTask+0x2e [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 373]
0d3ff78c 60b8534f xul!MessageLoop::DoWork+0x61 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 448]
0d3ff79c 60b84b3e xul!base::MessagePumpForUI::DoRunLoop+0x1f [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_pump_win.cc @ 216]
0d3ff7bc 60b84f39 xul!base::MessagePumpWin::RunWithDispatcher+0x3c [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_pump_win.cc @ 56]
0d3ff7c8 60b8d455 xul!base::MessagePumpWin::Run+0xb [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_pump_win.h @ 78]
0d3ff800 60b8d509 xul!MessageLoop::RunHandler+0x51 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 228]
0d3ff820 60b8fe1e xul!MessageLoop::Run+0x19 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\message_loop.cc @ 202]
0d3ff90c 60b856d7 xul!base::Thread::ThreadMain+0xa4 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\thread.cc @ 171]
0d3ff910 776c919f xul!`anonymous namespace'::ThreadFunc+0x9 [c:\builds\moz2_slave\rel-m-rel-w32_bld-000000000000\build\ipc\chromium\src\base\platform_thread_win.cc @ 27]
0d3ff91c 77cb0bbb kernel32!BaseThreadInitThunk+0xe
0d3ff960 77cb0b91 ntdll!__RtlUserThreadStart+0x20
0d3ff970 00000000 ntdll!_RtlUserThreadStart+0x1b
Milan, do you know who might be able to help figure out what's going on here?

Csaba, can you post the "Graphics" section of about:support on the Firefox profile where you see this?

Also, can you still reproduce this on the current release version (34) and/or on Nightly ( https://nightly.mozilla.org/ ) ?
Component: Untriaged → Graphics: Layers
Flags: needinfo?(milan)
Flags: needinfo?(csaba)
Product: Firefox → Core
(Reporter)

Comment 3

4 years ago
Hi Gijs,

I was able to reproduce this behavior with version 34. Happened after ~30 minutes while I was typing a url in the address bar.

Graphics
--------

Adapter Description: Intel(R) HD Graphics 3000
Adapter Description (GPU #2): NVIDIA GeForce GT 525M
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: Unknown
Adapter RAM (GPU #2): 1024
Device ID: 0x0116
Device ID (GPU #2): 0x0df5
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17111)
Driver Date: 8-21-2012
Driver Date (GPU #2): 10-23-2013
Driver Version: 9.17.10.2843
Driver Version (GPU #2): 9.18.13.3165
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 04ca1028
Subsys ID (GPU #2): 04ca1028
Vendor ID: 0x8086
Vendor ID (GPU #2): 0x10de
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(csaba)
We've been tracking this as bug 1067470.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(milan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1067470
You need to log in before you can comment on or make changes to this bug.