View Page Source sends GET even if displayed page was produced by POST

VERIFIED DUPLICATE of bug 55583

Status

--
minor
VERIFIED DUPLICATE of bug 55583
17 years ago
14 years ago

People

(Reporter: michael, Assigned: paulkchen)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101201

I've provided a page that illustrates the problem.

It seems that if a page is generated via HTTP POST (with form inputs), and one
clicks View Page Source, Mozilla performs a seperate request via GET to retrieve
the source.

The example also explains this in further detail once you've hit View Page Source.

While I have no idea what should govern when resubmitting something via HTTP
POST, I'm confident that the current behavior is clearly wrong (and mystifying).




Reproducible: Always
Steps to Reproduce:
1.Go to http://michael.bacarella.com/playground/breakmozilla.html
2.Fill in the fields. Try "Foo" and "Bar"
3.Read the resulting page.

Actual Results:  The page source being displayed is absolutely not the page that
was rendered in the browser.

Expected Results:  Ditto.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.