Restoring bookmarks from a backup fails

RESOLVED DUPLICATE of bug 1061672

Status

RESOLVED DUPLICATE of bug 1061672
4 years ago
4 years ago

People

(Reporter: javacatpaul, Unassigned)

Tracking

SeaMonkey 2.31 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0 SeaMonkey/2.31
Build ID: 20141202220728

Steps to reproduce:

using bookmark manager, creating a bookmark backup seems to work ok, the file gets created; but trying to restore that backup (after deleting places.sqlite) fails with "unable to read file xxx". It fails with either type of backup (.json or .jsonlz4) from any date on my pc.  It fails with either manually created backup or auto backups, from the same version of seamonkey or from one made months ago.

Presumably, this is why places.sqlite does not get automatically rebuilt when corrupted/deleted, as it used to do and the docs say it should.

Also, auto backups used to be made once per day; now they seem to be made much less often.  [the problem with the auto backups being zero-length has been fixed]

Exporting bookmarks to html and re-importing seems to be the only reliable way to save a backup of the bookmarks with this version of seamonkey.



Actual results:

backups would not restore



Expected results:

they should have been restored

Comment 1

4 years ago
> Presumably, this is why places.sqlite does not get automatically rebuilt

And yet that was just my supposition here, https://bugzilla.mozilla.org/show_bug.cgi?id=1093623#c4

> auto backups used to be made once per day

I've never seen, & still don't, any consistency in that regard.

> the auto backups being zero-length

While I do still have some existing, they are dated from Feb. 2014.

Anyhow...

DUP of Bug 1061672 - Import json-file from Firefox (or even from SeaMonkey) do not work
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061672
You need to log in before you can comment on or make changes to this bug.