[User story] As a link clicker in Chrome or Opera, I want to be advised to use Firefox for a better experience.

RESOLVED FIXED

Status

Hello (Loop)
Client
P4
enhancement
Rank:
42
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
x86_64
Windows 8
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

User Story

As a link clicker in Chrome or Opera, I want to be advised to use Firefox for a better experience.

Can be before joining or after leaving a conversation.
Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
Holly, Arcadio, is this something that the creative can help with to get the messaging right?
Flags: needinfo?(hhabstritt.bugzilla)
Flags: needinfo?(alainez)
(Reporter)

Updated

3 years ago
User Story: (updated)
(In reply to Romain Testard [:RT] from comment #1)
> Holly, Arcadio, is this something that the creative can help with to get the
> messaging right?

Matej's team can help with messaging, but when this user clicks a link they are brought into the Hello feature UI. So as I understand it, since any messaging and interaction from this point on in the non-Firefox browser would take place in the Hello feature UI, you'll need the Firefox UX and Engineering team to implement. (and not the web prod team, for example)
Flags: needinfo?(hhabstritt.bugzilla)

Comment 3

3 years ago
Romain...is this similar to Darrin's link clicker US in this spec: https://people.mozilla.org/~dhenein/labs/loop-link-spec/#call-start

Would there be conditional content based on how the user rates their conversation? For example, it feels wrong to ask the user to download Firefox if they rated the service poorly after they tried it.
Flags: needinfo?(alainez)
(Reporter)

Comment 4

3 years ago
(In reply to Holly Habstritt Gaal [:Habber] from comment #2)
> (In reply to Romain Testard [:RT] from comment #1)
> > Holly, Arcadio, is this something that the creative can help with to get the
> > messaging right?
> 
> Matej's team can help with messaging, but when this user clicks a link they
> are brought into the Hello feature UI. So as I understand it, since any
> messaging and interaction from this point on in the non-Firefox browser
> would take place in the Hello feature UI, you'll need the Firefox UX and
> Engineering team to implement. (and not the web prod team, for example)

When this user clicks a link they would be using the web link clicker UI (Chrome and Opera users). This bug is about promoting the use of Firefox to non Firefox link clickers, makes sense?
(Reporter)

Comment 5

3 years ago
(In reply to alainez from comment #3)
> Romain...is this similar to Darrin's link clicker US in this spec:
> https://people.mozilla.org/~dhenein/labs/loop-link-spec/#call-start
> 
> Would there be conditional content based on how the user rates their
> conversation? For example, it feels wrong to ask the user to download
> Firefox if they rated the service poorly after they tried it.

The link you have here is about the call URL. This bug is about the room link clickers.

WRT to your comment I am not sure. I would actually argue that if they rated it poorly a good argument would be to tell users to download Firefox for a better experience given we control the experience on Firefox and not other browsers. I think that regardless of the feedback provided we have a good reason to promote the use of Firefox instead: "You like it? Well it's better on Firefox" / "You did not like it? Probably you'll like it better on Firefox where we can control the experience more"
backlog: --- → Fx38?
(Reporter)

Comment 6

3 years ago
Sevaan, can you please help with UX here?
Flags: needinfo?(sfranks)
(Reporter)

Comment 7

3 years ago
Arcadio, as discussed yesterday can you please advise what messaging we should use here?
Should we offer the option to download Firefox prior to joining the room or when the user leaves the room after submitting feedback?

I think we can do both:
* Prior to joining a room there is a link somewhere allowing the user to download Firefox with a message informing the users that he can start creating his own conversations with Firefox. "Download Firefox to start your own conversations today."
* At the end of a call, after submitting feedback the user gets offered to download Firefox:
   - Positive feedback or no feedback sent: "You enjoyed Firefox Hello? Download Firefox to start your own conversations today."
   - Negative feedback sent: "We try our best to support <3rd party browser> although the experience is better on Firefox. Download Firefox for a better experience and start your own conversations today."

Thoughts?
Flags: needinfo?(alainez)
(Reporter)

Updated

3 years ago
Blocks: 1122439

Comment 8

3 years ago
Based on delay - this bug is a P4 and not actionable without decisions from marketing and then a request to Mataj for the creative content.
Severity: normal → enhancement
backlog: Fx38? → Fx38+
Priority: -- → P4

Comment 9

3 years ago
Let's make this a part of the conversation happening around this brief: https://docs.google.com/presentation/d/1I0iFa1npZwBf33ue-q61L6SF91yB1L1mDF1DBfiDLE0/edit?usp=sharing

I put something on your cal for Wednesday. We'll pick up comments on this bug afterwards. Clearing NI
Flags: needinfo?(alainez)
Duplicate of this bug: 1046304
Flags: needinfo?(sfranks)

Updated

3 years ago
backlog: Fx38+ → backlog+
Rank: 42
Flags: firefox-backlog+
(Reporter)

Comment 11

3 years ago
I am closing it since this is dealt with by the growth team who's planning on testing variations for this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.