Closed Bug 1109080 Opened 10 years ago Closed 3 months ago

treeView.js:158 throws an error in the Browser Console after selecting 'Cut' the second time from the sidebar's contextual menu

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox35 --- affected
firefox36 --- affected
firefox37 --- affected

People

(Reporter: avaida, Unassigned)

Details

(Keywords: regression)

Reproducible on: Firefox 35 Beta 2 (build1 / 20141208150535), Aurora 36.0a2 (2014-12-09), Nightly 37.0a1 (2014-12-09) and Firefox 34.0.5 (m-r / 20141126041045).

Affected platform(s): Windows 7 64-bit, Ubuntu 12.04 LTS 32-bit and Mac OS X 10.8.5.

STR:
1. Launch Firefox with a clean profile.
2. Enable the Browser Console from 'Web developer tools' (wrench button) → Browser Console.
3. Click the bookmarks menu button and choose 'View Bookmarks Sidebar'.
4. Collapse the 'Bookmarks Menu' and then the 'Recently Bookmarked' folder.
5. Right-click on 'About Us' bookmark and choose 'Cut'.
6. Right-click on the empty space below 'Unsorted Bookmarks' and choose 'Delete'.
7. Press CTRL + Z to undo the delete action.
8. Right-click on 'About Us' bookmark again and choose 'Cut'.
9. Check the Browser Console.

ER:
There are no errors thrown for this action.

AR:
The following error is thrown: 
> Error: Removed node passed to _getRowForNode in treeView.js:158
Sometimes, this error is also followed by:
> NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Removed node passed to 
> _getRowForNode" {file: "chrome://browser/content/places/treeView.js" line: 158}]'
> [JavaScript Error: "Removed node passed to _getRowForNode" {file:
> "chrome://browser/content/places/treeView.js" line: 158}]' when calling 
> method: [nsIController::doCommand]
> in controller.js:1798

Notes:
- Since this is reproducible on all branches, it might be a regression. I'll follow-up on this with a regression range as soon as possible.
Regression range (m-c):
* last good: 37516445a0b5 (2014-01-10)
* first bad: e89afc241513 (2014-01-11)
* pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=37516445a0b5&tochange=e89afc241513
* note: all past builds until 2014-01-10 are displaying only the following two errors for this scenario:
> [Exception... "'Error: Removed node passed to _getRowForNode' when calling method: 
> [nsIController::doCommand]"  nsresult: "0x8057001c 
> (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: 
> chrome://browser/content/places/controller.js :: goDoPlacesCommand :: 
> line 1657"  data: no] controller.js:1657
and
> NS_ERROR_XPC_JS_THREW_JS_OBJECT: 'Error: Removed node 
> passed to _getRowForNode' when calling method:
> [nsIController::doCommand] controller.js:1657
Keywords: regression
Priority: -- → P3
Severity: normal → S3

I don't think this is a bug because it seems this error is expected?

Should this bug be closed?

Flags: needinfo?(mak)

Error handling is good, we detect something wrong and we throw an exception. But if this condition would be expected we'd just bail out instead of throwing. We should check the stack and eventually fix the caller or remove th exception if it's an expected condition.

Flags: needinfo?(mak)

This issue no longer occurs in our latest Release version of Firefox 123.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.