Allow populating getAutocompleteInfo() when dom.forms.autocomplete.experimental is false

RESOLVED DUPLICATE of bug 1340477

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED DUPLICATE of bug 1340477
4 years ago
a year ago

People

(Reporter: MattN, Assigned: jdai)

Tracking

(Blocks: 3 bugs)

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [passwords:heuristics][form autofill:M3])

Attachments

(1 attachment)

Password manager (and possibly form manager) would like to know about valid @autocomplete values on field that we don't actually support for anything else (e.g. requestAutocomplete) yet.

For bug 917325, we need to know if a field has and autocomplete field type other than username/password ones so we know to ignore e.g. postal-code fields in our heuristics. We don't want to duplicate the logic for tokenizing/validating the values in each consumer in the meantime.
Flags: qe-verify-
Flags: firefox-backlog+
Hi Matt, can you provide a point value.
Iteration: --- → 37.2
Flags: needinfo?(MattN+bmo)
I'm not working on this for the iteration so that's why I didn't assign the iteration.
Iteration: 37.2 → ---
Flags: needinfo?(MattN+bmo)
Comment hidden (obsolete)

Updated

3 years ago
Whiteboard: HEu

Updated

3 years ago
Whiteboard: HEu → Heuristics+Recipes
Blocks: 939351
Someone else should feel free to take this from me if they would like.
Whiteboard: Heuristics+Recipes → [passwords:heuristics] [form autofill]
Whiteboard: [passwords:heuristics] [form autofill] → [passwords:heuristics][form autofill:MVP]
(Assignee)

Comment 5

a year ago
I would like to take this bug.
Assignee: MattN+bmo → jdai
Created attachment 8859406 [details] [diff] [review]
Old WIP patch

Here is my WIP patch from a few years ago. The main hurdle was dealing with the cached state. I wasn't sure if we should have two cached states of if it's fine to bypass the cache for code that wants experimental field names.
Whiteboard: [passwords:heuristics][form autofill:MVP] → [passwords:heuristics][form autofill:M3]
(Assignee)

Comment 7

a year ago
I'll fix this in bug 1340477.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1340477
You need to log in before you can comment on or make changes to this bug.