Closed Bug 1109527 Opened 5 years ago Closed 5 years ago

[Flame][Video]The half of the "Menu" button is not available in video play page.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: wangxin, Unassigned)

References

Details

(Keywords: regression)

Attachments

(7 files)

Attached video Bug video:1243.mp4
[1.Description]:
[Flame][v2.1&v2.2][Video]The first half of the "Menu" is not available, when you play a video in Video.
See bug video:"1243.MP4"
See detial picture:"1243.png"
See log:"logcat_1243.txt"

[2.Testing Steps]: 
1. Launch "Video".
2. Play a video.
3. Tap the "Menu" button.

[3.Expected Result]: 
All of the button should be launched.

[4.Actual Result]: 
Half of the "Menu" button is not available.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/cf8bebfa4703
Build-ID        20141209170126
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141209.212104
FW-Date         Tue Dec  9 21:21:15 EST 2014
Bootloader      L1TC00011880

Flame2.2 bulid:
Gaia-Rev        4cdeee67b449db90aae9384337311547c280093c
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/d7c76fe69e9a
Build-ID        20141209160204
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141209.192623
FW-Date         Tue Dec  9 19:26:39 EST 2014
Bootloader      L1TC00011880

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free test
Attached image Bug picture:1243.png
Top-right of the picture
This issue has been fixed on latest Flame2.1&2.2

Flame 2.1 build
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150104001209
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150104.034656
FW-Date         Sun Jan  4 03:47:06 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/55f3224d7513
Build-ID        20150104010206
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150104.043402
FW-Date         Sun Jan  4 04:34:12 EST 2015
Bootloader      L1TC000118D0
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Attached video Bug video: 2210.mp4
This issue will happened on latest Flame 2.2, So reopen it.
See video: "2210.mp4".
See log:"logcat_2210.txt"
Found time: 22:10
Occur rate: 5/5

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150113162504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.194114
FW-Date         Tue Jan 13 19:41:25 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(echang)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I find the similar problem about Settings icon on Flame v2.2 by the following steps.

Attch:settings_icon_1449.MP4 and logcat_1449.txt.
Reproduce rate: 5/6.
Found time:14:49.

Repro STR:
1.Launch Contacts.
2.Slide down contacts list.
3.Tap on "Search" icon on alphabetic list on the top right corner.
4.Tap on the blank area between the Search icon and Settings icon on the top right corner.
**Settings icon will gray out and device does not enter Settings page. --KO
5.Tap on Settings icon.
**Enter Settings page.

Flame v2.2 build: 
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/bccee1a13ba6
Build-ID        20150119002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.035831
FW-Date         Mon Jan 19 03:58:42 EST 2015
Bootloader      L1TC000118D0
Hi Eric,
Please refer Comment 4 and Comment 6
This issue also does exist when we do similar operations in different apps.
So reopen it.
It's not very responsive, right? But if you tap harder or leave your finger on for a couple more millisecond, is it still reproducible?
Flags: needinfo?(echang) → needinfo?(wangxin)
Hi Eric,
This is a very bad user experience. Sometimes, when you tap the center of an icon (this is the operation user generally would like to trigger related button function) 2 or 3 times, there is still no reaction.  And user has to tap the lower part of this icon to invoke related function.
Flags: needinfo?(wangxin) → needinfo?(echang)
Set 2.2? for regression
blocking-b2g: --- → 2.2?
Flags: needinfo?(echang)
Keywords: regression
Hi Eric,
    The regression information is as follows,hope this can help you.Thanks.

Last Working Environmental Variables:

Device: Flame
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a41cce2dd408
Build-ID        20150112040430
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.rose64.20150127.003948
FW-Date         Tue Jan 27 00:41:08 EST 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables:

Device: Flame
Gaia-Rev        b0254d13e67b0bd4c74c2f2c9b9ea1251949d9fe
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ee55ebb9d533
Build-ID        20150112060631
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.rose64.20150127.003948
FW-Date         Tue Jan 27 00:41:08 EST 2015
Bootloader      L1TC000118D0

First Broken Gaia & Last Working Gecko - issue does NOT repro

Gaia-Rev        b0254d13e67b0bd4c74c2f2c9b9ea1251949d9fe
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a41cce2dd408

First Broken Gecko & Last Working Gaia - issue DOES repro

Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ee55ebb9d533
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(echang)
See Also: → 1128556
I am unable to reproduce this on 2.2 latest build for both video and camera cases mentioned. 

Is this only happening on master now? Could it be related to any of the APZ changes that landed recently on master. Copying Katz to get his input. 

Thanks
Hema
I can reproduce this on master; it appears to be a result of the top gesture panel at [1]. Normally this panel overlaps the status bar at the top of the screen but in the video app the status bar is not shown and so the panel overlaps the top of the video app. Therefore the top 30 pixels of the video app cannot really be clicked on. If I click in the top-left corner I end up on the rocketbar search screen, for example.

[1] https://github.com/mozilla-b2g/gaia/blob/6a54af26e4a42f6b07cad04000f47deaa0f2c50b/apps/system/index.html#L1218
Thanks Coler, Kartikaya,
Per #c15, set status-b2g-v3.0 as affected.
The behavior seems to be on and off with v2.2, I cannot reproduce this on v2.2+319MB with today's build.
Flags: needinfo?(echang)
Interestingly, the status bar is also not shown in the gallery app preview mode. However, the 'back' button on the gallery app's preview screen starts at 2rem from the top, just below the status bar.

I don't think moving the gaia-header down 2rem in the video app would look acceptable.

It seems there should be a way to hide the system app top panel when the status bar is not shown.
Based on comment #15, this seems like a system app bug. Perhaps the top gesture panel should be reduced in size for fullscreen apps.  I don't know who works on the status bar.

Tim: when your team is back from new year, can you find someone to look at this?
Flags: needinfo?(timdream)
Component: Gaia::Video → Gaia::System::Window Mgmt
Flagging Gregor to see if he can assist during CNY.
Flags: needinfo?(anygregor)
B2G triage is blocking on touch target and sensitivity. User can't use the icon, effectively.
blocking-b2g: 2.2? → 2.2+
Status: REOPENED → NEW
Flags: needinfo?(timdream) → needinfo?(etienne)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #15)
> I can reproduce this on master; it appears to be a result of the top gesture
> panel at [1]. Normally this panel overlaps the status bar at the top of the
> screen but in the video app the status bar is not shown and so the panel
> overlaps the top of the video app. Therefore the top 30 pixels of the video
> app cannot really be clicked on. If I click in the top-left corner I end up
> on the rocketbar search screen, for example.
> 

The top panel was always designed to keep the same position in fullscreen apps. Enabling us to swipe from the top of the screen to show the statusbar and then access the rocketbar.

But we forward all taps to the app [1] when the statusbar is not displayed.

Pretty sure this a a duplicate of bug 1131695.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_statusbar.js#L110-114
Flags: needinfo?(etienne)
Does this issue still reproduce on latest master/2.2 builds? If it is a duplicate of bug 1131695 it should be fixed on master and 2.2.
Flags: needinfo?(wangxin)
This issue has been verified successfully on Flame2.2&3.0,

Flame 2.2 build:
Build ID               20150302002504
Gaia Revision          77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gaia Date              2015-02-27 16:35:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/27ab8aa34201
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.042723
Firmware Date          Mon Mar  2 04:27:34 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150302010223
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.043726
Firmware Date          Mon Mar  2 04:37:37 EST 2015
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Closed: 5 years ago5 years ago
Flags: needinfo?(wangxin)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Flags: needinfo?(anygregor)
You need to log in before you can comment on or make changes to this bug.