Video output is artifacting

RESOLVED FIXED

Status

()

Firefox for Android
Audio/Video
RESOLVED FIXED
3 years ago
11 months ago

People

(Reporter: Michael S, Unassigned)

Tracking

34 Branch
x86_64
Android
Points:
---

Firefox Tracking Flags

(firefox34 affected, firefox35 fixed, firefox36 fixed, firefox37 fixed)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

This seems (in my case) to be limited to the OnePlus One, as I've been unable to reproduce on a Galaxy S4 or Nexus 7 2013.

OnePlus One
Android 4.4.4 (stock CM builds)
FFv34.0

It seems that most gfycat HTML videos have this issue, as well as liveleak videos.

Example URL: http://www.liveleak.com/view?i=2e8_1418016501

Open the video and play it.


Actual results:

The video played with artifacting so heavy you can't make out the video, even though it does play as it should, with audio.


Expected results:

The video should have played the video without artifacting.

The video *does* work correctly on FF Beta (V35).
(Reporter)

Updated

3 years ago
OS: Windows 7 → Android
Thanks for the report. Let's mark this fixed via new media backend which will ship in Firefox 35 (we're evaluating risk for Firefox 34 currently).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Depends on: 1014614
Resolution: --- → FIXED
status-firefox34: --- → affected
status-firefox35: --- → fixed
status-firefox36: --- → fixed
status-firefox37: --- → fixed
You need to log in before you can comment on or make changes to this bug.