[Facebook]When linking pre made account to a facebook contact, a static image of the next screen appears

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: rmitchell, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-flame-reduced-run], )

Attachments

(1 attachment)

Reporter

Description

5 years ago
Description:
When linking pre made account to a facebook contact, a static image of the next screen flickers on the screen before opening the said screen 

Repro Steps:
1) Update a Flame to 20141210040201
2) Create a contact on phone > import contacts from facebook
3) Go to the created contact 
4) Tap link contact 


Actual:
Static flicker of the screen about to populated 


Expected:
clean transition 

Environmental Variables:
Device: Flame 2.2
Build ID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency:100%
See attached:logcat, video clip: http://youtu.be/awPhw2ckhTM
Flags: needinfo?(dharris)
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Reporter

Comment 1

5 years ago
One note for this bug, the contact created must have a picture before tapping the linking button.
QAwanted for branch checks
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: qawanted
QA Contact: croesch
Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: Screen flashes significantly when tapping the link contact button.

Repro Rate: 3/3

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141211040110
Gaia: 1a956437210d2b16988d2ddbf40c9a38d8474435
Gecko: d92db71d4e67
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK, Flame v188-1 Base

Actual Result: No screen flashing occurs when tapping the link button on a created contact with a picture after importing facebook contacts.

Repro Rate: 0/6

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141210190812
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: 9faa165ac85d
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141211052214
Gaia: 3deab7205f92cfad10f03a444fcdc7fbeee8e6b4
Gecko: b8d376961705
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame v188-1 Base
BuildID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
Nomming for 2.2 -  Regression, Poor UX (looks bad)
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Contact: jmercado
triage: obvious defect, regression
blocking-b2g: 2.2? → 2.2+
Bug 1085223 seems to have caused this issue

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141020171137
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: 223e2f4b0d47
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141020172632
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: fa9c6845338e
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: fa9c6845338e

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: 223e2f4b0d47

Gecko Pushlog: hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=223e2f4b0d47&tochange=fa9c6845338e
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
This issue appears to be cause by the patch to Bug 1085223 - can you take a look Matt?
Blocks: 1085223
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(matt.woodrow)
QA Contact: jmercado
Taking a look to this.
Assignee: nobody → francisco
Flags: needinfo?(matt.woodrow)
I am not able to repro on today's master[1]. RJ, would you mind checking if you have the issue on a recent build? If you can't, let's close this bug as works for me.

[1] Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/636498d041b5
Build-ID        20150105010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  65
FW-Date         Mon Dec 15 18:51:29 CST 2014
Bootloader      L1TC000118D0
Flags: needinfo?(rmitchell)
RJ is no longer here - adding QA-Wanted tag to check latest build
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(rmitchell)
Keywords: qawanted
This issue is still reproducing on latest build. One key point that's missing in STR comment 0 is that at step 2 the contact needs to have a picture assigned to it. And then when tapping on Link Contact, there will be flickering of screen before displaying the result.

Tested on:
Device: Flame 2.2 Master (shallow flash)
BuildID: 20150105033341
Gaia: 4ceeff19086b2a2955f044ad923dcfa63a293de3
Gecko: 912036eeb024
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi,

after following comment 11 and adding a picture I can see the problem, but I think is a graphics related issue.

I'm attaching a video where you can see, the same contact detail, when we display the contact image in the viewport we will get the flickering error, and when the same contact detail we scroll down and we don't show the image on the viewport, there is no error at all.

https://drive.google.com/file/d/0B3RfQh7fuZjAbjdIVjFfU21qLWs/view?usp=sharing

I'm moving this to graphics, please set the correct component if I'm wrong and is not a graphics problem.
Component: Gaia::Contacts → Graphics: Layers
Product: Firefox OS → Core
Assignee: francisco → nobody

Comment 13

5 years ago
Milan, please help for evaluation. thanks.
Flags: needinfo?(msreckovic)

Updated

5 years ago
Flags: needinfo?(msreckovic) → needinfo?(milan)
Don't know how long it'll be before Matt is cleared from MSE work.  Benoit, you reviewed bug 1085223 which regressed this - I wonder if there is something you can add or suggest somebody else that can look at this?
Assignee: nobody → matt.woodrow
Flags: needinfo?(milan) → needinfo?(bgirard)
Yes, I'm familiar with this code.
Assignee: matt.woodrow → bgirard
I tried reproducing without importing a contact from Facebook but it doesn't work.

With a local build I get 'Invalid App Id: 123456'. How do I get around that to reproduce the issue?
Flags: needinfo?(bgirard)
This is the default App ID defined[1]. If you want to use the real App Id you could, either make an official build[2] of change the default app ID by the real one.

[1] https://github.com/mozilla-b2g/gaia/blob/5818ef2f416fb1324cf1c5fdb59cdefd0ca454af/build/config/communications_services.json#L8
[2] https://github.com/mozilla-b2g/gaia/blob/c5c452110d0c6da80cf1f08a06904a14bc228504/build/contacts-import-services.js#L29
Ok the above works.

But with a master build I cannot reproduce the issue. I'm going to get a v2.2 build ready. Meanwhile if someone can confirm that the issue on master is fixed that would be handy.
I'm unable to reproduce with v2.2 or master.

Updated

4 years ago
Status: NEW → ASSIGNED
A fix to culling landed in bug 1113435. Can this be reproduced?
Assignee: bgirard → nobody
Flags: needinfo?(rmitchell)

Comment 21

4 years ago
qawanted to check if this still reproduce
Keywords: qawanted
This issue no longer occurs as of today's central tinderbox build.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150305063634
Gaia: 0017f2bbc63781a5409644b664d80ebaa1543653
Gecko: f95de08c795a
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(rmitchell) → needinfo?(ktucker)
Keywords: qawanted
This also no longer occurs on the latest 2.2 tinderbox build.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150305093010
Gaia: eb86137e247224e86d17ed1a0a133b2a318dce3c
Gecko: daa71bcd85cf
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Closing this as worksforme. Please feel free to reopen this issue if encountered again.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.