[Smart Collection] Creating a second smart collection results in a black screen.

VERIFIED DUPLICATE of bug 1124816

Status

Firefox OS
Gaia::Homescreen
VERIFIED DUPLICATE of bug 1124816
3 years ago
3 years ago

People

(Reporter: SMiko, Unassigned)

Tracking

({regression})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8534663 [details]
Smart.txt

Description: A black screen is displayed when creating a second smart collection. Tapping the black screen will briefly display the selection menu before closing and returning the user to the homescreen. 

Repro Steps:
1: Update a Flame to 20141210040201.
2: Long press on the homescreen to bring up the menu and select "Add Smart Collection."
3: Select "Share" or "Don't Share" on the app permission page. 
4: Select a smart collection type and create the smart collection.
5: Repeat step 2.

Actual: A black screen is displayed. 

Expected: The user is able to complete the smart collection creation flow. 

Environmental Variables:
Device: Flame 2.2 (319mb/full flash)
BuildID: 20141210040201
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Notes:
1: This issue does NOT occur when the app permission message displays prior to creating the smart collection. 

Repro frequency: 5/5

See attached: logcat 

Video clip: http://youtu.be/FPkwo8_cY9w
(Reporter)

Comment 1

3 years ago
This issue does NOT repro on Flame 2.1 (319mb/full flash)

Actual result: No black screen is seen. User can create multiple smart collections. 

Environmental Variables:
Device: Flame 2.1
BuildID: 20141210001201
Gaia: c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko: cf8bebfa4703
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing][systemsfe]
Functional Regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
Unable to reproduce issue. 

Actual Results: Adding a Smart Collection to homescreen does not result in a black screen.

Repro Attempts: 0/20 

Device: Flame 2.2 (Shallow Flash, engineering, 319 MB memory)
BuildID: 20141211040110
Gaia: 1a956437210d2b16988d2ddbf40c9a38d8474435
Gecko: d92db71d4e67
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Leaving tag for other testers to attempt.
blocking-b2g: 2.2? → 2.2+

Updated

3 years ago
QA Contact: ddixon
The STR listed here was used to find the Regression Window.

STR:
1. Flash to build
2. Turn on SIM pin via Settings app
3. Restart phone
4. Enter SIM pin to activate Data connection
5. Longpress homescreen to add Smartcollection

Note: Having a SIM pin enabled seems to help the bug reproduce consistently.

B2G Inbound Regression Window

Last Working

Device: Flame 2.2
BuildID: 20141106221308
Gaia: 284253475469b58d549fa48aee67dd1fc814dbc9
Gecko: 90d6489edae2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken

Device: Flame 2.2
BuildID: 20141106225407
Gaia: 83eaaae5fc609aa414d27a13a0237acb2d647a3a
Gecko: 742640491a42
Version: 36.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia and First Broken Gecko
Issue DOES NOT occur here.
Gaia: 284253475469b58d549fa48aee67dd1fc814dbc9
Gecko: 742640491a42

Last Working Gecko and First Broken Gaia
Issue DOES occur here.
Gaia: 83eaaae5fc609aa414d27a13a0237acb2d647a3a
Gecko: 90d6489edae2

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/284253475469b58d549fa48aee67dd1fc814dbc9...83eaaae5fc609aa414d27a13a0237acb2d647a3a

Possible Cause:

Bug 1062819 - Implement MobileConnectionCore and corresponding sub sy…
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
This issue seems to be caused by 1062819 - Alive can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(alive)

Comment 6

3 years ago
I can take a look at this.
Assignee: nobody → aus
Status: NEW → ASSIGNED
Flags: needinfo?(alive)
Target Milestone: --- → 2.2 S3 (9jan)
Assignee: aus → dale
I havent been able to reproduce this (and just blew away a sim by screwing up the sim pin code), alive any chance you can take a look to see if this still reproduces? it seems like a window management / value_selector issue if it does
Assignee: dale → nobody
This one should be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1124816
Reopen if disagree
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124816
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.