crash in libxul.so@0x680a88 | libxul.so@0x680b25 | VisitAbove and [@ libxul.so@0x680a88 | libxul.so@0x680b25 | nsRegion::VisitEdges(void (*)(void*, VisitSide, int, int, int, int), void*) ]

RESOLVED DUPLICATE of bug 1107931

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1107931
4 years ago
2 years ago

People

(Reporter: Ioana Chiorean, Unassigned)

Tracking

({crash})

Trunk
All
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-b6dd3707-6afe-4301-9bdb-343182141211
report bp-7f21ab43-5188-4140-945a-559f92141211

Steps:
1. Go to: http://mozillamemory.org/browse.php?search=&type=still_image&cat=people
2. Pan/ Zoom/ Go to next page ( first, last)
It crashes for me all the time

Note: Got 2 similar reports so I've added a bug for both

=============================================================
 0 	libxul.so 	libxul.so@0x680a88 	
1 	libxul.so 	libxul.so@0x680b25 	
2 	libxul.so 	VisitAbove 	gfx/src/nsRegion.cpp
3 	libxul.so 	nsRegion::VisitEdges(void (*)(void*, VisitSide, int, int, int, int), void*) 	gfx/src/nsRegion.cpp
4 	libxul.so 	mozilla::layers::PadDrawTargetOutFromRegion(mozilla::RefPtr<mozilla::gfx::DrawTarget>, nsIntRegion&) 	gfx/src/nsRegion.h
5 	libxul.so 	mozilla::layers::ClientTiledLayerBuffer::ValidateTile(mozilla::layers::TileClient, nsIntPoint const&, nsIntRegion const&) 	gfx/layers/client/TiledContentClient.cpp
6 	libxul.so 	mozilla::layers::TiledLayerBuffer<mozilla::layers::ClientTiledLayerBuffer, mozilla::layers::TileClient>::Update(nsIntRegion const&, nsIntRegion const&) 	gfx/layers/TiledLayerBuffer.h
7 	libxul.so 	mozilla::layers::ClientTiledLayerBuffer::PaintThebes(nsIntRegion const&, nsIntRegion const&, void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*) 	gfx/layers/client/TiledContentClient.cpp
8 	libxul.so 	mozilla::layers::ClientTiledPaintedLayer::RenderHighPrecision(nsIntRegion&, nsIntRegion const&, void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*) 	gfx/layers/client/ClientTiledPaintedLayer.cpp
9 	libxul.so 	mozilla::layers::ClientTiledPaintedLayer::RenderLayer() 	gfx/layers/client/ClientTiledPaintedLayer.cpp
10 	libxul.so 	RunnableMethodTraits<FdWatcher>::RetainCallee(FdWatcher*) 	ipc/chromium/src/base/task.h
11 	libxul.so 	mozilla::layers::ClientContainerLayer::RenderLayer() 	gfx/layers/client/ClientContainerLayer.h
12 	libxul.so 	RunnableMethodTraits<FdWatcher>::RetainCallee(FdWatcher*) 	ipc/chromium/src/base/task.h
13 	libxul.so 	mozilla::layers::ClientContainerLayer::RenderLayer() 	gfx/layers/client/ClientContainerLayer.h
14 	libxul.so 	mozilla::layers::ClientLayerManager::EndTransactionInternal(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) 	gfx/layers/client/ClientLayerManager.cpp
15 	libxul.so 	mozilla::layers::ClientLayerManager::EndTransaction(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) 	gfx/layers/client/ClientLayerManager.cpp
16 	libxul.so 	nsDisplayList::PaintRoot(nsDisplayListBuilder*, nsRenderingContext*, unsigned int) 	layout/base/nsDisplayList.cpp
17 	libxul.so 	nsLayoutUtils::PaintFrame(nsRenderingContext*, nsIFrame*, nsRegion const&, unsigned int, unsigned int) 	layout/base/nsLayoutUtils.cpp
18 	libxul.so 	PresShell::Paint(nsView*, nsRegion const&, unsigned int) 	layout/base/nsPresShell.cpp
19 	libxul.so 	nsViewManager::ProcessPendingUpdatesPaint(nsIWidget*) 	view/nsViewManager.cpp
20 	libxul.so 	nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) 	view/nsViewManager.cpp
21 	libxul.so 	nsRefreshDriver::Tick(long long, mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp
22 	libxul.so 	mozilla::RefreshDriverTimer::Tick() 	layout/base/nsRefreshDriver.cpp
23 	libxul.so 	nsTimerImpl::Fire() 	xpcom/threads/nsTimerImpl.cpp
24 	libxul.so 	nsTimerEvent::Run() 	xpcom/threads/nsTimerImpl.cpp
25 	libxul.so 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
26 	libxul.so 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
27 	libxul.so 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
28 	libxul.so 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
29 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
30 	libxul.so 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
31 	libxul.so 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
32 	libxul.so 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
33 	libxul.so 	XREMain::XRE_main(int, char**, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp
34 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp
35 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp
36 	libmozglue.so 	Java_org_mozilla_gecko_mozglue_GeckoLoader_nativeRun 	mozglue/android/APKOpen.cpp
Ø 37 	libdvm.so 	libdvm.so@0x1dc4e 	
Ø 38 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x3b13c5 	
Ø 39 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x8e4ac6 	
Ø 40 	dalvik-heap (deleted) 	dalvik-heap (deleted)@0x8cc576 	
Ø 41 	libdvm.so 	libdvm.so@0x4ded1 	
Ø 42 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x3b13c3 	
43 	libmozglue.so 	Java_org_mozilla_gecko_mozglue_GeckoLoader_loadNSSLibsNative 	mozglue/android/APKOpen.cpp
44 		@0x221fffff 	
45 	libmozglue.so 	Java_org_mozilla_gecko_mozglue_GeckoLoader_loadNSSLibsNative 	mozglue/android/APKOpen.cpp

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1107931
You need to log in before you can comment on or make changes to this bug.