crash in mozalloc_abort(char const* const) | NS_DebugBreak | nsDebugImpl::Abort(char const*, int)

RESOLVED DUPLICATE of bug 1035290

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 1035290
3 years ago
3 years ago

People

(Reporter: lizzard, Unassigned)

Tracking

({crash, topcrash})

34 Branch
x86
Windows NT
crash, topcrash
Points:
---

Firefox Tracking Flags

(firefox34 affected)

Details

(crash signature)

[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-74d12cef-d0b8-47a9-8750-bfb4f2141210.
=============================================================
This crash signature has come back into the top 10 for 34 with 683/47826 crashes in the last 3 days, and 1255/91832 crashes for 34.0.5.
Some comments mention Flash, plugin container issues, and an inability to shutdown. 


Crashing thread:

0 	mozalloc.dll 	mozalloc_abort(char const* const) 	memory/mozalloc/mozalloc_abort.cpp
1 	xul.dll 	NS_DebugBreak 	xpcom/base/nsDebugImpl.cpp
2 	xul.dll 	nsDebugImpl::Abort(char const*, int) 	xpcom/base/nsDebugImpl.cpp
3 	xul.dll 	NS_InvokeByIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke.cpp
4 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
5 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
6 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
7 	mozjs.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
8 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
9 	mozjs.dll 	js::CallOrConstructBoundFunction(JSContext*, unsigned int, JS::Value*) 	js/src/jsfun.cpp
10 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
11 	mozjs.dll 	js_fun_call(JSContext*, unsigned int, JS::Value*) 	js/src/jsfun.cpp
12 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
13 	mozjs.dll 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
14 	mozjs.dll 	js::DirectProxyHandler::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) 	js/src/jsproxy.cpp
15 	mozjs.dll 	js::CrossCompartmentWrapper::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) 	js/src/jswrapper.cpp

top URLs:
about:addons
https://www.facebook.com/
about:cehome
about:newtab
http://www.firefox.com.cn/desktop/tips/
about:home
about:blank
about:sessionrestore
This report matches bug 1017706.
I have written a dashboard specifically for this signature, you may find it here: http://yoric.github.io/are-we-shutting-down-yet-/ – just be gentle, the socorro server doesn't enjoy responding to the requests of an external dashboard app.
So, see http://yoric.github.io/are-we-shutting-down-yet-/?signature=%7EFHR%3A+Flushing+storage+shutdown
Sorry, wrong bug number. That was bug 1035290.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035290
Clearly tracking flag. I tracked the dup instead.
tracking-firefox34: ? → ---
You need to log in before you can comment on or make changes to this bug.