Regression: vertical bars painted in tiles on screen when scrolling

VERIFIED FIXED in Firefox 35

Status

()

defect
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: BenWa)

Tracking

({regression, reproducible, testcase})

37 Branch
Firefox 37
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox34 unaffected, firefox35+ verified, firefox36+ verified, firefox37+ verified, fennec35+)

Details

()

Attachments

(1 attachment)

Reporter

Description

5 years ago
Currently on Nightly (12/11), Aurora (12/11), Beta (mozilla-beta 35), when scrolling through content rapidly one will see vertical bars painted on-screen (likely depending on content).

See video: http://youtu.be/wwfoMz_0pvY

Using the e.g, URL to demonstrate this behaviour 

  http://ihackernews.com/comments/8730903
  
mozilla-inbound pushlog

  https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=97068dca449e&tochange=81eafec98b48

mwoodrow@mozilla.com
Wed Oct 08 00:13:22 2014 +0000	81eafec98b48	Matt Woodrow — Bug 1077842 - Simplify invalid regions for tiled painted layers to avoid complex region operations. r=jrmuizel

43c963b56723	Matt Woodrow — Bug 1078109 - Make sure we initialize tiled textures to the format we're going to upload with. r=jgilbert

--
Nightly (12/11)
LG Nexus 5 (Android 5.0)
Flags: in-testsuite?
Reporter

Updated

5 years ago
Assignee: nobody → matt.woodrow
Status: NEW → ASSIGNED
Is this Android L only, do we know?
Reporter

Comment 2

5 years ago
(In reply to Milan Sreckovic [:milan] from comment #1)
> Is this Android L only, do we know?

No. I can reproduce this on Android 4.x as well (e.g, my HTC One, S4/S5)
This sounds like bug 1073554.
Reporter

Updated

5 years ago
Severity: normal → major
Keywords: testcase
tracking-fennec: ? → 35+
Reporter

Comment 4

5 years ago
I don't think we can ship Firefox 35 with this bug, it's embarrassing.
Jeff, do you have a device where this reproduces?
Flags: needinfo?(jgilbert)
I tried a build with matt's patches mentioned in comemnt #0 backed out. Before the backout I saw both horizontal and vertical dark lines when scrolling quickly. With the backout I only see the horizontal ones.
Assignee

Updated

5 years ago
Duplicate of this bug: 1118858
Assignee

Comment 8

5 years ago
Posted patch patchSplinter Review
This patch fixes the problem for me. A small tweak to how we do progressive painting. I don't feel very excited to put this on beta however without specific QA resources for this.
Assignee: matt.woodrow → bgirard
Flags: needinfo?(jgilbert)
Attachment #8545412 - Flags: review?(nical.bugzilla)
Assignee

Comment 9

5 years ago
Comment on attachment 8545412 [details] [diff] [review]
patch

Review of attachment 8545412 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/client/TiledContentClient.cpp
@@ +1508,5 @@
>      if (!aRegionToPaint.IsEmpty()) {
> +      if (mResolution != CSSToParentLayerScale(1)) {
> +        // Paint the entire tile for low-res. This is aimed to fixing low-res resampling
> +        // and to avoid doing costly region accurate painting for a small area.
> +        aRegionToPaint = tileBounds;

We might want to insert with the visible region instead of the thebes callback doesn't allow us to specific a region larger than the layer.
Assignee

Updated

5 years ago
See Also: → 1073554

Comment 12

5 years ago
[Tracking Requested - why for this release]:

(In reply to Aaron Train [:aaronmt] from comment #4)
> I don't think we can ship Firefox 35 with this bug, it's embarrassing.

Given that, it should be tracking.
Attachment #8545412 - Flags: review?(nical.bugzilla) → review+
Comment on attachment 8545412 [details] [diff] [review]
patch

We need this in asap because of bug 1073554 so we're going ahead with uplift based on QE manual testing and also that we're going to do a b11 build to ship by EOD tomorrow so we can collect more data.
Attachment #8545412 - Flags: approval-mozilla-release+
Attachment #8545412 - Flags: approval-mozilla-beta+
Attachment #8545412 - Flags: approval-mozilla-aurora?
Attachment #8545412 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assignee

Comment 17

5 years ago
Thanks for the help here. It's appreciated.
https://hg.mozilla.org/mozilla-central/rev/142bb8c88b3b
https://hg.mozilla.org/mozilla-central/rev/6698118c0b54
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37

Comment 20

5 years ago
Verified as fixed in Firefox 35 beta 11;
Device: Samsung Galaxy S4 (Android 4.4.2).

Comment 21

5 years ago
Verified as fixed builds:
- 37.0a1 2015-01-09;
- 36.0a2 2015-01-09;

Device: Samsung Galaxy S4 (Android 4.4.2).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.