Closed Bug 1110307 Opened 5 years ago Closed 5 years ago

create hotfix to undo the effects of 1110209

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mconnor, Assigned: Felipe)

References

Details

Attachments

(4 files, 2 obsolete files)

bug 1110209 regressed partner builds for en-US builds.  We're going to switch to pushing 34.0 updates for those users, but we need to undo the damage here.

Gavin says this will be easy, I'm sure he'll delegate though.
OS: Windows 8.1 → All
Hardware: x86_64 → All
Attached patch hotfix codeSplinter Review
This is untested, but I think this is the code we want. Felipe, can you drive this through ASAP?
Attachment #8535112 - Flags: review?(felipc)
We will need to test this very quickly. Kev, can you provide some Steps to Reproduce? I think they are roughly:

1) Install 33.1 partner build (https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/33.1-candidates/build1/partner-repacks/)
2) Update to 34.0.5

Expected: search engine default does not change
Actual: search engine changes to Yahoo

Once that was reproduce, this hotfix is intended to undo the unintentional change.

3) Install hotfix
4) Confirm that engine reverts to engine from step 1)
Note that pushing another hotfix will disable the addon hotfix.
Yup

1) Install 33.1 en-US Partner Build (e.g. Aol) onto clean profile
2) Verify Aol is set as default search
3) Update to 34.0.5
4) Verify default search engine

Expected: Search engine default matches distribution default
Actual: Search engine is changed to Yahoo
Comment on attachment 8535112 [details] [diff] [review]
hotfix code

Review of attachment 8535112 [details] [diff] [review]:
-----------------------------------------------------------------

Only thing I was gonna mention is that there's usually only one hotfix at a time deployed, so it would stop the previous one from hitting users. IIRC there was once in the past where custom AMO code was written to feed different hotfixes depending on the FF version, but given the time constraints of this one that sounds unlikely

::: v20141211.01/bootstrap.js
@@ +38,5 @@
> +  // If we are a distribution build.
> +  if (distroID) {
> +    try {
> +      // Override the special "isUS" logic.
> +      Services.prefs.setBoolPref("browser.search.isUS", false);

Quite a useful thing now that this caching exists

@@ +40,5 @@
> +    try {
> +      // Override the special "isUS" logic.
> +      Services.prefs.setBoolPref("browser.search.isUS", false);
> +      // Note that we applied this hotfix in case that is useful later.
> +      Services.prefs.setBoolPref("browser.hotfix.v20141211.applied", true);

All code looks fine. Only question is if you would want this pref browser.hotfix.v20141211.applied also set for non-distro builds (in case it's useful later)
Attachment #8535112 - Flags: review?(felipc) → review+
Attached file XPI to test - hotfix-v20141211.01.xpi (obsolete) —
Unsigned XPI for testing
Attached file XPI to test - hotfix-v20141211.01.xpi (obsolete) —
If anyone has better luck testing the update than I, here's an updated version which fixes the getCharPref problem spotted. I changed the getter of the "distribution.id" pref to use the default branch
Updating repro steps, because it turns out it's edge-case if there's a bundled toolbar which sets the default search engine in user prefs (like Aol does).

To repro with an Aol build, do the following:

- Install Aol Fx 31.1.1
- Start Firefox with a clean profile
- Uninstall Aol toolbar
- Select a non-default from the search box drop-down
- Select Aol as default from the search box drop-down
- Update Firefox to 34.0.5

Expected: Search engine default matches distribution default
Actual: Search engine is changed to Yahoo
I promise I'll get this right soon. The bundled toolbar only writes the default engine in user prefs on install, so if the user at any time flips to a non-default search engine and then back to the distribution default, it will be updated to Yahoo as default.

Updating repro steps, because it turns out it's edge-case if there's a bundled toolbar which sets the default search engine in user prefs (like Aol does).

To repro with an Aol build, do the following:

- Install Aol Fx 31.1.1
- Start Firefox with a clean profile
- Select a non-default from the search box drop-down
- Select Aol as default from the search box drop-down
- Update Firefox to 34.0.5

Expected: Search engine default matches distribution default
Actual: Search engine is changed to Yahoo

If you don't change the search engine on a fresh install, you'll get updated properly to Aol. When you flip from the distribution default to another provider and then back, we remove the user pref because the selected engine is the distribution/app default.
With an empty chrome.manifest file. It's unclear if it's needed but I added just in case.
Attachment #8535134 - Attachment is obsolete: true
Attachment #8535157 - Attachment is obsolete: true
Depends on: 1110452
And a follow-up, the code that tried to force-refresh the selected engine before a restart wouldn't work properly if the user had switched engines to something else, so we nixed it. The fix provided by the hotfix will take effect after a restart of the browser.

http://hg.mozilla.org/releases/firefox-hotfixes/rev/015b9ea24cdc
The hotfix is now on the staging server for AMO and I've done a basic check that it's working from staging. I used a version 34.0.5 with a distribution.id, and using the instructions at:
https://developer.mozilla.org/en-US/Add-ons/Hotfix#Testing_the_hotfix_on_the_staging_server

Verified that the hotfix was downloaded and performed its desired action. But it would be always good to get more testing on this (I did this on OSX Yosemite and didn't perform the full update STRs from comment 8)
Has anyone verified that this still provides the addon hotfix for non-distribution.id users?
Flags: needinfo?(gavin.sharp)
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #14)
> Has anyone verified that this still provides the addon hotfix for
> non-distribution.id users?

Not sure I understand the question. The hotfix is designed to do nothing for non-distribution users, since they are not affected by the bug. We should validate that beyond the testing Felipe has done (Kamil has offered to help).

We cannot serve both the update hotfix and this hotfix at the same time, apparently, so we're going to replace the update hotfix with this hotfix for some time, until we're confident most users have received this fix.
Flags: needinfo?(gavin.sharp)
In that case, who will own disabling this hotfix and replacing the former one when that confidence has been reached?  Should we file another bug and track to ensure it doesn't fall off the radar?
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #16)
> In that case, who will own disabling this hotfix and replacing the former
> one when that confidence has been reached?  Should we file another bug and
> track to ensure it doesn't fall off the radar?

I think we'll need to re-submit the current hotfix with a bumped up version number.
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #16)
> In that case, who will own disabling this hotfix and replacing the former
> one when that confidence has been reached?  Should we file another bug and
> track to ensure it doesn't fall off the radar?

How about we tentatively schedule that to happen alongside/after the 35 release?
Yes, we should get another bug on file.

At the 35 release sounds like a reasonable plan.
I reproduced the original issue using the following build:
- https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/33.1-candidates/build1/partner-repacks/aol/

Test Cases used:
================

33.1 > 34.0.5

- ensured that AOL is being listed as the default under search settings
- ensured that "browser.search.defaultenginename;AOL Search" once the hotfix was applied
- ensured that "extensions.hotfix.lastVersion;20141211.01" once the hotfix was applied
- ensured that AOL search stays the default search engines after restarting fx several times
- ensured that searching via the URL bar, about:home, about:newtab correctly used AOL search once it's reverted back via the hotfix
- changed the default search engine to something else and restarted fx several times, ensured that it's not being restored to AOL
- ensured that when changing AOL as the default, it's correctly appearing under "one-click search engines" via the search settings (also checked the search toolbar)

34.0.5

* ensured that Yahoo isn't being changed when it's the default search engine
* ensured that DuckDuckGo isn't being changed when it's the default search engine

Used the following method to test the hotfix:
=============================================

33.1 > 34.0.5

* Downloaded the fx 33.1 candidate mentioned above
* once downloaded/installed, updated to 34.0.5 using the firefox-33.1-34.0.5.partial.mar from the following location:
** http://download.cdn.mozilla.net/pub/mozilla.org/firefox/releases/latest/update
** followed: https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file
* after the update was completed, checked update.status and ensured it displayed "succeeded" (also checked about:support and ensured it appeared as 34.0.5)
* ensured that the search engine was appearing as "Yahoo" rather than "AOL"
* followed the instructions from the link provided in comment # 13
* after waiting a few minutes, the add-on manager checked for updated (log listed below)

34.0.5

* Downloaded the latest version of fx 34.0.5 using:
** http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/
* Once downloaded/installed, attempted to apply the hotfix using the steps from comment # 13

Console Log from OSX:
=====================

Could not read chrome manifest 'file:///Applications/Firefox.app/Contents/Resources/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
Bootstrapped manifest not allowed to use 'overlay' directive. chrome.manifest:1
1418615799494 addons.xpi DEBUG Calling bootstrap method uninstall on firefox-hotfix@mozilla.org version 20141211.01
1418615799494 addons.xpi DEBUG uninstallAddon: flushing jar cache /Users/kjozwiak/Library/Application Support/Firefox/Profiles/flimhi28.default/extensions/firefox-hotfix@mozilla.org.xpi for addon firefox-hotfix@mozilla.org
1418615799495 DeferredSave.extensions.json DEBUG Save changes
1418615799496	addons.xpi DEBUG removeTemporaryFile: https://addons-dev-cdn.allizom.org/user-media/addons/354399/mozilla_firefox_hotfix-20141211.01-fx.xpi removing temp file /Users/kjozwiak/Library/Caches/TemporaryItems/tmp-rsd.xpi
1418615799579	DeferredSave.extensions.json DEBUG Starting write
1418615799582	DeferredSave.extensions.json DEBUG Write succeeded

Tested on the following OS's:
=============================

* OSX 10.10.1 x64
* Win 8.1 x64 (ran into an issue #1, see below)
* Ubuntu 14.04.1 x86

Possible Issues:

Issue #1:

When going through basically the same steps that I followed with OSX, I receive the following error on Windows 8.1 x64:
* used steps from: https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file

1418623206631 addons.xpi WARN Failed to install C:\Users\KAMILJ~1\AppData\Local\Temp\tmp-9tg.xpi from https://addons-dev-cdn.allizom.org/user-media/addons/354399/mozilla_firefox_hotfix-20141211.01-fx.xpi: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: recursiveRemove :: line 1312"  data: no] Stack trace: recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1312 < forEach()@self-hosted:221 < recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1327 < forEach()@self-hosted:221 < recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1327 < forEach()@self-hosted:221 < recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1327 < DirInstallLocation_getTrashDir()@resource://gre/modules/addons/XPIProvider.jsm:7157 < DirInstallLocation_installAddon()@resource://gre/modules/addons/XPIProvider.jsm:7179 < AI_startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5636 < TaskImpl_run()@resource://gre/modules/Task.jsm:330 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:865 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744 < <file:unknown>

Once you get that error message, the AOL search isn't reverted back until you restart fx. Once you restart the browser, the AOL search engines becomes the default once again (sometimes it takes a few seconds). After that, everything seems to be working. I also noticed that the "extensions.hotfix.lastVersion" pref is not present once the hotfix is applied on Win 8.1 x64.

Gavin/Felipe, I'm not sure if I did this correctly by installing the .mar files manually. I tried going through the updater, but it would only update me to 34.0. Let me know if I did this incorrectly and I can run through it again pretty quickly now that I know the process. If I did it incorrectly, could someone please let me know the correct way to update fx to 34.0.5. I have a dentist appointment tomorrow at 11:00am EST but should be back in less than 2 hours. I'll wake up early to see if there's any responses.
(In reply to Kamil Jozwiak [:kjozwiak] from comment #20)
> I reproduced the original issue using the following build:
> -
> https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/33.1-candidates/
> build1/partner-repacks/aol/
> 
> Test Cases used:
> ================
> 
> 33.1 > 34.0.5
> 
> - ensured that AOL is being listed as the default under search settings
> - ensured that "browser.search.defaultenginename;AOL Search" once the hotfix
> was applied
> - ensured that "extensions.hotfix.lastVersion;20141211.01" once the hotfix
> was applied
> - ensured that AOL search stays the default search engines after restarting
> fx several times
> - ensured that searching via the URL bar, about:home, about:newtab correctly
> used AOL search once it's reverted back via the hotfix
> - changed the default search engine to something else and restarted fx
> several times, ensured that it's not being restored to AOL
> - ensured that when changing AOL as the default, it's correctly appearing
> under "one-click search engines" via the search settings (also checked the
> search toolbar)
> 
> 34.0.5
> 
> * ensured that Yahoo isn't being changed when it's the default search engine
> * ensured that DuckDuckGo isn't being changed when it's the default search
> engine
> 
> Used the following method to test the hotfix:
> =============================================
> 
> 33.1 > 34.0.5
> 
> * Downloaded the fx 33.1 candidate mentioned above
> * once downloaded/installed, updated to 34.0.5 using the
> firefox-33.1-34.0.5.partial.mar from the following location:
> **
> http://download.cdn.mozilla.net/pub/mozilla.org/firefox/releases/latest/
> update
> ** followed:
> https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file
> * after the update was completed, checked update.status and ensured it
> displayed "succeeded" (also checked about:support and ensured it appeared as
> 34.0.5)
> * ensured that the search engine was appearing as "Yahoo" rather than "AOL"
> * followed the instructions from the link provided in comment # 13
> * after waiting a few minutes, the add-on manager checked for updated (log
> listed below)
> 
> 34.0.5
> 
> * Downloaded the latest version of fx 34.0.5 using:
> ** http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/
> * Once downloaded/installed, attempted to apply the hotfix using the steps
> from comment # 13
> 
> Console Log from OSX:
> =====================
> 
> Could not read chrome manifest
> 'file:///Applications/Firefox.app/Contents/Resources/browser/extensions/
> %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
> Bootstrapped manifest not allowed to use 'overlay' directive.
> chrome.manifest:1
> 1418615799494 addons.xpi DEBUG Calling bootstrap method uninstall on
> firefox-hotfix@mozilla.org version 20141211.01
> 1418615799494 addons.xpi DEBUG uninstallAddon: flushing jar cache
> /Users/kjozwiak/Library/Application
> Support/Firefox/Profiles/flimhi28.default/extensions/firefox-hotfix@mozilla.
> org.xpi for addon firefox-hotfix@mozilla.org
> 1418615799495 DeferredSave.extensions.json DEBUG Save changes
> 1418615799496	addons.xpi DEBUG removeTemporaryFile:
> https://addons-dev-cdn.allizom.org/user-media/addons/354399/
> mozilla_firefox_hotfix-20141211.01-fx.xpi removing temp file
> /Users/kjozwiak/Library/Caches/TemporaryItems/tmp-rsd.xpi
> 1418615799579	DeferredSave.extensions.json DEBUG Starting write
> 1418615799582	DeferredSave.extensions.json DEBUG Write succeeded
> 
> Tested on the following OS's:
> =============================
> 
> * OSX 10.10.1 x64
> * Win 8.1 x64 (ran into an issue #1, see below)
> * Ubuntu 14.04.1 x86
> 
> Possible Issues:
> 
> Issue #1:
> 
> When going through basically the same steps that I followed with OSX, I
> receive the following error on Windows 8.1 x64:
> * used steps from:
> https://wiki.mozilla.org/Software_Update:Manually_Installing_a_MAR_file
> 
> 1418623206631 addons.xpi WARN Failed to install
> C:\Users\KAMILJ~1\AppData\Local\Temp\tmp-9tg.xpi from
> https://addons-dev-cdn.allizom.org/user-media/addons/354399/
> mozilla_firefox_hotfix-20141211.01-fx.xpi: [Exception... "Component returned
> failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]" 
> nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame ::
> resource://gre/modules/addons/XPIProvider.jsm :: recursiveRemove :: line
> 1312"  data: no] Stack trace:
> recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1312 <
> forEach()@self-hosted:221 <
> recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1327 <
> forEach()@self-hosted:221 <
> recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1327 <
> forEach()@self-hosted:221 <
> recursiveRemove()@resource://gre/modules/addons/XPIProvider.jsm:1327 <
> DirInstallLocation_getTrashDir()@resource://gre/modules/addons/XPIProvider.
> jsm:7157 <
> DirInstallLocation_installAddon()@resource://gre/modules/addons/XPIProvider.
> jsm:7179 <
> AI_startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:5636 <
> TaskImpl_run()@resource://gre/modules/Task.jsm:330 <
> Handler.prototype.process()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:865 <
> this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm ->
> resource://gre/modules/Promise-backend.js:744 < <file:unknown>

Can you install and uninstall other add-ons in this system?

Also, in this case, can you check if the pref "browser.hotfix.v20141211.applied" exists after the engine was successfully reverted?
Attached image afterHOTFIX.png
> Can you install and uninstall other add-ons in this system?
> 
> Also, in this case, can you check if the pref "browser.hotfix.v20141211.applied" exists after the engine > was successfully reverted?

I went through the Win 8.1 x64 test case once again (3x) and checked about:config but couldn't find the following prefs:
- browser.hotfix.v20141211.applied
- extensions.hotfix.lastVersion

After receiving the above error in the browser console I restarted fx and received AOL as the default search engine. At that point I installed both "Addblock Plus" and "Ghostery" without any issues nor errors registering in the browser console. I also didn't run into any problems while uninstalling both of the add-ons.

However I did notice some strange behaviour with the AOL toolbar. Perhaps related to the error we are receiving? When the hotfix is applied from about:addons, most of the icons on the AOL toolbar "disappear". The "Edit" and "Search the Web" buttons are left behind and Yahoo still appears as the default search provider. Once you restart fx, the toolbar appears to be restored back to the original state while the default search engine changes back to AOL. I've attached two images:

Image: afterHOTFIX -> this is how the toolbar looks right after the hotfix is applied
Image: afterRestartingFX -> once fx has been restarted, returns to normal and AOL is used as the default search engine
After talking to Gavin, I also tested the following method rather than using the .mar approach:

- created a new profile using fx 33.1
- installed fx 34.0.5 and opened the profile created from the 33.1 build
- changed the appropriate settings using https://developer.mozilla.org/en-US/Add-ons/Hotfix#Testing_the_hotfix_on_the_staging_server
- restarted fx and waited until about:addons installed the hotfix

Results:

Windows 8.1 x64: (ran 2x)

- received the same error in the browser console once the hotfix was applied
- most of the icons disappeared from the AOL toolbar until fx was restarted (see comment # 22 for images)
- Yahoo was still appearing as the default search engine until fx was restarted
- Both extensions.hotfix.lastVersion and browser.hotfix.v20141211.applied were missing from about:config (even after the restart)

OSX 10.10.1 x64: (ran 2x)

- ran into the same issue with the toolbar (comment #22), AOL was switched to default after being restarted
- extensions.hotfix.lastVersion appeared under about:config
- browser.hotfix.v20141211.applied didn't appear under about:config (checked right after update and after restart)
- didn't receive the error that's being displayed on Windows

Ubuntu 14.04.1 x86: (ran 2x)

- ran into the same issue with the toolbar (comment #22), AOL was switched to default after being restarted
- extensions.hotfix.lastVersion appeared under about:config
- browser.hotfix.v20141211.applied appeared under about:config
- didn't receive the error that's being displayed on Windows
The AOL toolbar seems to be messing with things and reverting the default engine to AOL by itself and masquerading the test results.

Let's use the steps from comment 8 (and not comment 9) to test. Let's ensure that the hotfix works as expected, and then we can see how the toolbar is affecting things. 

Full steps:

- Install Aol Fx 31.1.1
- Start Firefox with a clean profile
- Uninstall Aol toolbar
- Select a non-default from the search box drop-down
- Select Aol as default from the search box drop-down

* verify that the pref "distribution.id" is present and set to "aol"

- Update Firefox to 34.0.5

* verify that distribution.id is still present
* verify that the pref "browser.search.isUS" is set to true
* verify that Yahoo is now the default search engine

- Install the hotfix

* verify that the pref "browser.search.isUS" was switched to false
* verify that the pref "browser.hotfix.v20141211.applied" was created
* verify that "extensions.hotfix.lastVersion" was set to the correct value

- Restart Firefox

* verify that AOL was restored as the default engine
Looks like it's working correctly once you remove the AOL toolbar and update 33.1 manually using firefox-33.1-34.0.5.partial.mar. Installing 34.0.5 directly over 33.1 will remove the "distribution.id" preference.

Results:

- Windows 8.1 x64 - PASSED (ran through the test case x2)
- Ubuntu 14.04.1 x86 - PASSED (ran through the test case x2)

After 34.0.5 update via firefox-33.1-34.0.5.partial.mar:

* distribution.id;aol still present
* browser.search.isUS;true
* browser.search.order.1;data:text/plain,browser.search.order.1=AOL Search
* browser.search.order.US.1;Yahoo

After hotfix applied:

* browser.search.isUS;false
* extensions.hotfix.lastVersion;20141211.01
* browser.hotfix.v20141211.applied;true
* distribution.id;aol is still present
* AOL restored as the default engine

- OSX 10.10.1 x64 -  FAILED (ran through the test case x5)

* browser.search.order.1;Google
* browser.search.order.US.1;Yahoo
* distribution.id is missing
* browser.hotfix.v20141211.applied missing
* browser.search.isUS;true

Looks like it's failing on my OSX machine. I tried going through the test cases 5 different times without any luck. Once I updated to 34.0.5, the "distribution.id" pref was removed. I went through the entire process either way and "Yahoo" was kept as the default search engine after the restart. Not sure if the update is different on OSX from Win/Ubuntu?
Hey, did this get stalled with the Mac issues?  We still need this at least on Windows/Linux...
What is the status of this, Felipe?
Assignee: gavin.sharp → felipc
Flags: needinfo?(felipc)
I retested the hotfix to check the issues about the AOL toolbar, and couldn't reproduce the icons disappearing neither through a manual install of the hotfix (drag & dropping), or by waiting for the update ping (through the staging server).  Perhaps it was a temporary issue with the toolbar itself (which seems to load dynamic content for the icons, weather forecast, etc).

We can release the hotfix now, which will fix Win+Linux users, but won't be effective in fixing OSX users, or we can wait for a fix to bug 1113222 and release the hotfix afterwards to include OSX users too.

I suggest we release it now, and since it looks like the fix to bug 1113222 will also be in the format of a hotfix, the code here can be included in that hotfix which would fix the two issues at once for OSX.
Flags: needinfo?(felipc)
Jorge, can you deploy to production the hotfix that was staged in bug 1110452? We've got a green light from release-drivers to ship it.
Flags: needinfo?(jorge)
The hotfix is now live.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jorge)
Resolution: --- → FIXED
Added a description of this hotfix to README file
https://hg.mozilla.org/releases/firefox-hotfixes/rev/be16e4a0b695
You need to log in before you can comment on or make changes to this bug.