Closed Bug 1111150 Opened 5 years ago Closed 5 years ago

crypto.getRandomValues is not available in jsm webworker

Categories

(Core :: DOM: Workers, defect)

34 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 842818

People

(Reporter: willscott, Unassigned)

Details

Attachments

(1 file)

2.31 KB, application/zip
Details
Attached file addon.zip
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2224.3 Safari/537.36

Steps to reproduce:

From a JSM context within a firefox addon, create a Worker. In that worker, call crypto.createRandomValues


Actual results:

 Worker says: 
  typeof crypto is: undefined


Expected results:

crypto.createRandomValues should be defined, as it is in standard web workers.
Component: Untriaged → DOM: Workers
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842818
You need to log in before you can comment on or make changes to this bug.