Closed Bug 1111546 Opened 8 years ago Closed 4 years ago

Enable client/inspector/shared/test/browser_styleinspector_tooltip-closes-on-new-selection.js in e10s

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: pbro, Assigned: jdescottes)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [btpp-backlog])

Attachments

(1 file)

Test /browser/devtools/styleinspector/test/browser_styleinspector_tooltip-closes-on-new-selection.js frequently fails with E10S enabled.

See this try build for example: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=5fab0cdd5353

It seems to be timing out here:

function* testRuleView(ruleView, inspector) {
  info("Showing the tooltip");
  let tooltip = ruleView.tooltips.previewTooltip;
  let onShown = tooltip.once("shown");
  tooltip.show();
  yield onShown; // --> Times out here
  ...
}

tooltip here is a Tooltip object as defined here: http://mxr.mozilla.org/mozilla-central/source/browser/devtools/shared/widgets/Tooltip.js#177

Calling show just calls this.panel.openPopup(...) (where this.panel is the XUL panel used by the tooltip).
And the Tooltip class emits "shown" events when the XUL panel does.

I've never seen this test fail without E10S.
Test /browser/devtools/styleinspector/test/browser_styleinspector_tooltip-size.js suffers from the exact same symptoms, so I'm going to add it to this bug.

Instead of failing to show the XUL panel, it fails to hide it (but that may be intermittent too):

  let onHidden = tooltip.once("hidden");
  tooltip.hide();
  yield onHidden;
Summary: Enable test browser_styleinspector_tooltip-closes-on-new-selection.js on E10S → Enable tests browser_styleinspector_tooltip-closes-on-new-selection.js and browser_styleinspector_tooltip-size.js with E10S
Depends on bug 1104908 since that's the bug I'm going to disable both of these tests in.
Depends on: 1104908
Summary: Enable tests browser_styleinspector_tooltip-closes-on-new-selection.js and browser_styleinspector_tooltip-size.js with E10S → [e10s] Enable tests browser_styleinspector_tooltip-closes-on-new-selection.js and browser_styleinspector_tooltip-size.js with E10S
Inspector bug triage. Filter on CLIMBING SHOES

Tests are still disabled.
Priority: -- → P3
Whiteboard: [btpp-backlog]
Product: Firefox → DevTools
tracking-e10s: + → ---
Duplicate of this bug: 1478249
Blocks: 1387330
This _might_ be fixed now that we switched to the HTMLTooltip. It passes with --verify for me, let's check on try, enable and fix if it becomes intermittent again.
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Summary: [e10s] Enable tests browser_styleinspector_tooltip-closes-on-new-selection.js and browser_styleinspector_tooltip-size.js with E10S → Enable client/inspector/shared/test/browser_styleinspector_tooltip-closes-on-new-selection.js in e10s
Comment on attachment 8994758 [details]
Bug 1111546 - Enable browser_styleinspector_tooltip-closes-on-new-selection.js;

https://reviewboard.mozilla.org/r/259290/#review266264
Attachment #8994758 - Flags: review?(pbrosset) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8273ed227bbc
Enable browser_styleinspector_tooltip-closes-on-new-selection.js;r=pbro
https://hg.mozilla.org/mozilla-central/rev/8273ed227bbc
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
You need to log in before you can comment on or make changes to this bug.