crash when trying to read mail

RESOLVED DUPLICATE of bug 1111304

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED DUPLICATE of bug 1111304
3 years ago
3 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

Trunk
x86_64
Linux

SeaMonkey Tracking Flags

(seamonkey2.34 affected)

Details

(crash signature)

Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0 SeaMonkey/2.34a1 ID:20141214003001 c-c:673f3227b36a m-c:f14dcd1c8c0b

Reproducible: Always

Steps to Reproduce:
Variant A:
1. Select an email in the Threads pane.
2. Click the divider grippy to open the preview pane.
Variant B:
1. Select an email in the Threads pane.
2. Hit F8 to open the preview pane.
Variant C:
1. Double-click an email in the Threads pane.

If it makes any difference, I was trying to open the latest internal email in the Unix MoveMail inbox.

Actual result:
Variants A and B: Immediate crash.
Variant C: A message window opens, with some chrome but no contents; then SeaMonkey crashes.

Expected result:
The preview pane or message window should open normally, with no crash.

Additional information:

This did not happen in the previous nightly.

The following factors all contributed to high CPU load (>95% on both sides of this 2.8 GHz Pentium 4 HT), with attendant higher risk of races and timeouts:
1. I am booting with "Fan: Silent (minimum noise, may reduce CPU performance)" selected in the BIOS setup because otherwise the machine doesn't stay up. (As soon as I have the money I'll get me a newer model.)
2. A music CD was playing (J.S.Bach's Well-Tempered Clavier by Glenn Gould).
3. The browser was still busy loading (5 tabs at a time) its 116-tab session as part of startup.

Crash IDs:
Variant A:
bp-856c404c-a0a7-4e69-b72b-fdfc22141215
bp-f0dffd4a-63dd-490d-9cf3-fd5352141215
Variant B:
bp-cafa246e-ae73-49d0-a74a-e44602141215
Variant C:
bp-f503f1d3-a50e-4225-9c33-6cf8b2141215

Here comes the Soccorro report from Variant C:
Signature 	nsIOService::NewChannelFromURIWithProxyFlags2(nsIURI*, nsIURI*, unsigned int, nsIDOMNode*, nsIPrincipal*, nsIPrincipal*, unsigned int, unsigned int, nsIChannel**) More Reports Search
UUID 	f503f1d3-a50e-4225-9c33-6cf8b2141215
Date Processed	2014-12-15 11:56:06.931049
Uptime	1076
Last Crash	1172 seconds before submission
Install Age 	68153 since version was first installed.
Install Time 	2014-12-14 16:58:12
Product 	SeaMonkey
Version 	2.34a1
Build ID 	20141214003001
Release Channel 	nightly
OS 	Linux
OS Version 	0.0.0 Linux 3.11.10-21-desktop #1 SMP PREEMPT Mon Jul 21 15:28:46 UTC 2014 (9a9565d) x86_64
Build Architecture 	amd64
Build Architecture Info 	family 15 model 4 stepping 1 | 2
Crash Reason 	SIGSEGV
Crash Address 	0x0
User Comments 	Open a message in its own window by clicking it in the threads pane. The message window opened, with some chrome but no content, and then the crash happened.
App Notes 	

OpenGL: VMware, Inc. -- Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits) -- 2.1 Mesa 9.2.3 -- texture_from_pixmap

Processor Notes 	sp-processor05_phx1_mozilla_com.11637:2012; MozillaProcessorAlgorithm2015; skunk_classifier: reject - not a plugin hang
EMCheckCompatibility 	

False

Winsock LSP 	

Adapter Vendor ID 	

Adapter Device ID 	

Bugzilla - Report this bug in SeaMonkey Core Plugins Toolkit
Related Bugs

    1111341RESOLVED DUPLICATE crash in nsIOService::NewChannelFromURIWithProxyFlags2(nsIURI*, nsIURI*, unsigned int, nsIDOMNode*, nsIPrincipal*, nsIPrincipal*, unsigned int, unsigned int, nsIChannel**)
    1111304NEW --- assertion failure loadinfo

Crashing Thread
Frame 	Module 	Signature 	Source
0 	libxul.so 	nsIOService::NewChannelFromURIWithProxyFlags2(nsIURI*, nsIURI*, unsigned int, nsIDOMNode*, nsIPrincipal*, nsIPrincipal*, unsigned int, unsigned int, nsIChannel**) 	/builds/slave/c-cen-t-lnx64-ntly/build/objdir/dist/include/nsILoadInfo.h:96
1 	libxul.so 	nsIOService::NewChannelFromURI2(nsIURI*, nsIDOMNode*, nsIPrincipal*, nsIPrincipal*, unsigned int, unsigned int, nsIChannel**) 	netwerk/base/src/nsIOService.cpp
2 	libxul.so 	NS_NewChannelInternal(nsIChannel**, nsIURI*, nsINode*, nsIPrincipal*, nsIPrincipal*, unsigned int, unsigned int, nsILoadGroup*, nsIInterfaceRequestor*, unsigned int, nsIIOService*) 	netwerk/base/public/nsNetUtil.h
3 	libxul.so 	NS_NewChannelInternal(nsIChannel**, nsIURI*, nsILoadInfo*, nsILoadGroup*, nsIInterfaceRequestor*, unsigned int, nsIIOService*) 	netwerk/base/public/nsNetUtil.h
4 	libxul.so 	nsDocShell::DoURILoad(nsIURI*, nsIURI*, bool, unsigned int, nsISupports*, char const*, nsAString_internal const&, nsIInputStream*, nsIInputStream*, bool, nsIDocShell**, nsIRequest**, bool, bool, bool, nsAString_internal const&, nsIURI*, unsigned int) 	docshell/base/nsDocShell.cpp
5 	libxul.so 	nsDocShell::InternalLoad(nsIURI*, nsIURI*, unsigned int, nsISupports*, unsigned int, char16_t const*, char const*, nsAString_internal const&, nsIInputStream*, nsIInputStream*, unsigned int, nsISHEntry*, bool, nsAString_internal const&, nsIDocShell*, nsIURI*, nsIDocShell**, nsIRequest**) 	docshell/base/nsDocShell.cpp
6 	libxul.so 	nsDocShell::LoadURI(nsIURI*, nsIDocShellLoadInfo*, unsigned int, bool) 	docshell/base/nsDocShell.cpp
7 	libxul.so 	nsMailboxService::FetchMessage(char const*, nsISupports*, nsIMsgWindow*, nsIUrlListener*, char const*, int, char const*, nsIURI**) 	/builds/slave/c-cen-t-lnx64-ntly/build/mailnews/local/src/nsMailboxService.cpp:239
8 	libxul.so 	nsMailboxService::DisplayMessage(char const*, nsISupports*, nsIMsgWindow*, nsIUrlListener*, char const*, nsIURI**) 	/builds/slave/c-cen-t-lnx64-ntly/build/mailnews/local/src/nsMailboxService.cpp:274
9 	libxul.so 	nsMessenger::OpenURL(nsACString_internal const&) 	/builds/slave/c-cen-t-lnx64-ntly/build/mailnews/base/src/nsMessenger.cpp:440
10 	libxul.so 	nsMsgDBView::LoadMessageByViewIndex(unsigned int) 	/builds/slave/c-cen-t-lnx64-ntly/build/mailnews/base/src/nsMsgDBView.cpp:1109
11 	libxul.so 	nsMsgGroupView::LoadMessageByViewIndex(unsigned int) 	/builds/slave/c-cen-t-lnx64-ntly/build/mailnews/base/src/nsMsgGroupView.cpp:899
12 	libxul.so 	NS_InvokeByIndex 	xpcom/reflect/xptcall/md/unix/xptcinvoke_x86_64_unix.cpp
13 	libxul.so 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
14 	libxul.so 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
15 	libxul.so 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
16 	libxul.so 	Interpret 	js/src/vm/Interpreter.cpp
17 	libxul.so 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
18 	libxul.so 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
19 	libxul.so 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
20 	libxul.so 	JS::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::HandleValueArray const&, JS::MutableHandle<JS::Value>) 	js/src/jsapi.cpp
21 	libxul.so 	mozilla::dom::Function::Call(JSContext*, JS::Handle<JS::Value>, nsTArray<JS::Value> const&, JS::MutableHandle<JS::Value>, mozilla::ErrorResult&) 	/builds/slave/c-cen-t-lnx64-ntly/build/objdir/dom/bindings/FunctionBinding.cpp:36
22 	libxul.so 	void mozilla::dom::Function::Call<nsCOMPtr<nsISupports> >(nsCOMPtr<nsISupports> const&, nsTArray<JS::Value> const&, JS::MutableHandle<JS::Value>, mozilla::ErrorResult&, mozilla::dom::CallbackObject::ExceptionHandling) 	/builds/slave/c-cen-t-lnx64-ntly/build/objdir/dist/include/mozilla/dom/FunctionBinding.h:58
23 	libxul.so 	nsGlobalWindow::RunTimeoutHandler(nsTimeout*, nsIScriptContext*) 	dom/base/nsGlobalWindow.cpp
24 	libxul.so 	nsGlobalWindow::RunTimeout(nsTimeout*) 	dom/base/nsGlobalWindow.cpp
25 	libxul.so 	nsGlobalWindow::TimerCallback(nsITimer*, void*) 	dom/base/nsGlobalWindow.cpp
26 	libxul.so 	nsTimerImpl::Fire() 	xpcom/threads/nsTimerImpl.cpp
27 	libxul.so 	nsTimerEvent::Run() 	xpcom/threads/nsTimerImpl.cpp
28 	libxul.so 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
29 	libxul.so 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
30 	libxul.so 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
31 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
32 	libxul.so 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
33 	libxul.so 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
34 	libxul.so 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
35 	libxul.so 	XREMain::XRE_main(int, char**, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp
36 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp
37 	seamonkey 	do_main 	/builds/slave/c-cen-t-lnx64-ntly/build/suite/app/nsSuiteApp.cpp:205
38 	seamonkey 	main 	/builds/slave/c-cen-t-lnx64-ntly/build/suite/app/nsSuiteApp.cpp:389
Ø 39 	libc-2.18.so 	libc-2.18.so@0x21be4 	
40 	seamonkey 	do_main 	/builds/slave/c-cen-t-lnx64-ntly/build/suite/app/nsSuiteApp.cpp:209


Adding the RelEng team to the CC because the crashing source is in an objdir tree.

Comment 1

3 years ago
(In reply to Tony Mechelynck from comment #0)
> Related Bugs
> 
>     1111341RESOLVED DUPLICATE crash in
> nsIOService::NewChannelFromURIWithProxyFlags2(nsIURI*, nsIURI*, unsigned
> int, nsIDOMNode*, nsIPrincipal*, nsIPrincipal*, unsigned int, unsigned int,
> nsIChannel**)
>     1111304NEW --- assertion failure loadinfo
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1111304
You need to log in before you can comment on or make changes to this bug.