If network delays or other issues occur while creating a room, user gets no feedback at all

RESOLVED FIXED in mozilla37

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dmose, Assigned: standard8)

Tracking

unspecified
mozilla37
Points:
2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 1109151])

(Reporter)

Description

4 years ago
A simple way to reproduce one case of this is to simply turn off your Wifi or unplug your network and then drop the panel down and click "Start Conversation".  The panel closes, and no other behavior is visible.

The case where the client code decides there is an actual error is already covered by 1109149.  

In the cases where there's just network congestion and things are slow, the user should (at the very least) see some sort of progress indicator, and be in a position to either retry or simply give up.

We could consider keeping the panel open and having a spinning progress indicator in a dimmed out room entry, perhaps.
(Reporter)

Updated

4 years ago
backlog: --- → Fx35?
I'm not sure I would hard-block on this (so I've made it a P2), but I would definitely love to get this into Fx35.  It's currently at the top of my P2s for Fx35.  I'll add it to the trello.
backlog: Fx35? → Fx35+
Priority: P1 → P2
Actually, now that I've had a chance to think about it.  I think we need to do something.  Let's make this bug about doing something basic with the intent of uplifting it into Fx35 and then file follow up bugs to improve the behavior in future releases.
Priority: P2 → P1
Mark -- Would it make sense for you to take this since you're already taking bug 1109149?
Flags: needinfo?(standard8)
Assignee: nobody → standard8
Flags: needinfo?(standard8)
No longer blocks: 1109151
Depends on: 1109151
Whiteboard: [being fixed in bug 1109151]
I've fixed this in bug 1109151.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [being fixed in bug 1109151] → [fixed by bug 1109151]
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.