[Window Management] Opening Email before Camera can lead to non functional buttons

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: KTucker, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-2], URL)

Attachments

(1 attachment)

Created attachment 8536738 [details]
Logcat of the camera icons not working

If the user opens the "Email" app, opens the "Camera" app and then taps the "front facing" camera, "flash" and "menu" icons, the buttons will stop working. The user will be unable to take a picture with the camera.

Prerequisite: No email account setup on the device.

Repro Steps:
1)  Updated Flame to Build ID: 20141215040201
2)  Open the "Email" app.
3)  Open the camera app and immediately tap on the "front facing" camera, "flash" and "menu" icons.
4)  Try to take a picture and tap on the icons again in step 3.

Actual:
All the buttons in camera are non-functional.

Expected:
All buttons function properly without issue.

Environmental Variables
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141215040201
Gaia: e2a3e606675c346b6e6f35351a458040be599b09
Gecko: f14dcd1c8c0b
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Notes:
Repro frequency: 90%
See attached: video,logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This issue does not occur on the Flame 2.1

All buttons in the camera app function as intended after opening the email app and then going into camera.

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141215001202
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: ec87f4f41d3d
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Not nominating to block on this bug. This bug will occur based on the timing of tapping the camera buttons right when it opens and can be hard to get.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 3

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.