JavascriptException: JavascriptException: TypeError: settings is null at: app://system.gaiamobile.org/gaia_build_index.js line: 241

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: anshulj, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [caf priority: p2][CR 786382])

Attachments

(1 attachment)

Reporter

Description

5 years ago
I am seeing the following exception while running marionette test cases related to voice calls, which is causing the test to fail. 

JavascriptException: JavascriptException: TypeError: settings is null at: app://system.gaiamobile.org/gaia_build_index.js line: 241


The exception seems to be coming from http://lxr.mozilla.org/gaia/source/shared/js/dump.js#24
Reporter

Comment 1

5 years ago
I am seeing errors below just before the exception, not sure if they are related.

12-15 12:37:17.436 E/Usage   ( 1655): Content JS ERROR: net-error 
12-15 12:37:17.436 E/Usage   ( 1655):     at initPage (about:neterror?e=fileNotFound&u=app%3A//costcontrol.gaiamobile.org/message_handler.html&c=UTF-8&f=app&m=app%3A//costcontrol.gaiamobile.org/manifest.webapp&d=Firefox%20can%27t%20find%20the%20file%20at%20app%3A//costcontrol.gaiamobile.org/message_handler.html.:1165:6965)
12-15 12:37:17.436 E/Usage   ( 1655):     at ee_emit (about:neterror?e=fileNotFound&u=app%3A//costcontrol.gaiamobile.org/message_handler.html&c=UTF-8&f=app&m=app%3A//costcontrol.gaiamobile.org/manifest.webapp&d=Firefox%20can%27t%20find%20the%20file%20at%20app%3A//costcontrol.gaiamobile.org/message_handler.html.:925:88)
12-15 12:37:17.436 E/Usage   ( 1655):     at setReady (about:neterror?e=fileNotFound&u=app%3A//costcontrol.gaiamobile.org/message_handler.html&c=UTF-8&f=app&m=app%3A//costcontrol.gaiamobile.org/manifest.webapp&d=Firefox%20can%27t%20find%20the%20file%20at%20app%3A//costcontrol.gaiamobile.org/message_handler.html.:1088:79)
12-15 12:37:17.436 E/Usage   ( 1655):     at onL10nLoaded (about:neterror?e=fileNotFound&u=app%3A//costcontrol.gaiamobile.org/message_handler.html&c=UTF-8&f=app&m=app%3A//costco
Anshul, does this happen for every voice call (even for the very first one) or does this show up after some time?

Brian, do we see this issue in our endurance tests as well?
Flags: needinfo?(brhuang)
Walter, could you check for this? Thx.
Flags: needinfo?(brhuang) → needinfo?(wachen)
I need more information. For example, the build id(date, branch, and so on), version info(v2.1 or v2.2 ...?), base image(v188 or ...?).

Also, more detailed information would be appreciated. For example, is it happening randomly, at the very first time, and/or the frequency of this issue.
Flags: needinfo?(wachen)
Flags: needinfo?(anshulj)
Reporter

Comment 5

5 years ago
(In reply to Walter Chen[:ypwalter][:wachen] from comment #4)
> I need more information. For example, the build id(date, branch, and so on),
> version info(v2.1 or v2.2 ...?), base image(v188 or ...?).
> 
> Also, more detailed information would be appreciated. For example, is it
> happening randomly, at the very first time, and/or the frequency of this
> issue.
The issue happens every time I run some GSM call related unit tests. The issue is reproducible on v2.2 on any recent builds. I don't have a specific test that causes this issue; I can try and narrow it down.
Flags: needinfo?(anshulj)
Any updates here? Can we get a reduced STR?
Reporter

Comment 7

5 years ago
Greg, I am seeing some other issues with our unit test script preventing me to test this use case. I will update this bug as soon as I am able to reproduce it.
Reporter

Comment 8

5 years ago
I am seeing the issue in the following scenario

1. Make a call
2. Reject the call by the other party
3. Repeat steps 1 - 2 couple of times
4. Make a call
5. Accept the call
6. Hangup the call by the other party

Note that I am only able to reproduce this issue using marionette tests only. Also, once I increase the delay between each of the above steps I see the issue less often.
Whiteboard: [CR 786382]
Whiteboard: [CR 786382] → [caf priority: p2][CR 786382]
Can we reproduce this issue with the STR in comment 8?
Flags: needinfo?(wachen)
Tim, can you work with Walter on this?
Flags: needinfo?(timdream)
I don't really think STR of comment 1, comment 2 and comment 8 are the same.

I can definitely work with Walter provided that he could identify this bug really represents.
Flags: needinfo?(timdream)
SPoke offline with walter and he can help with this!

Comment 13

4 years ago
Tim,

Have you been able to make any progress on this with Walter?

Thanks,
Mike
Flags: needinfo?(timdream)
not reproducible by comment 8:
1. Make a call
2. Reject the call by the other party 
   the phone on caller side won't hang call automatically, need to hang the call again from caller
3. Repeat steps 1 - 2 couple of times
4. Make a call
5. Accept the call
6. Hangup the call by the other party

Tried different ways of dialing and none of them are working. The message is showing some kind of error related with cost control. Is it possible that it is something about voice call by a specific SIM card with 3G/3.5G/4G network on? Can you tell us more about sim data/voice plan and its service provider?

Flame:
Build ID               20150223162505
Gaia Revision          389542b71c89253c0d176d3b0bfb54e275c19bf1
Gaia Date              2015-02-22 20:32:37
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/81bcdde1e783
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150223.202034
Firmware Date          Mon Feb 23 20:20:45 EST 2015
Bootloader             L1TC100118D0
Flags: needinfo?(wachen)
Flags: needinfo?(timdream)
QA Contact: wachen
Is it still reproducible recently?
Flags: needinfo?(anshulj)
Reporter

Comment 16

4 years ago
Yes it is still reproducible on v2.2
Gecko: fe489912aac2f83b14e7286b8f92443f6c6b64a7
Gaia: ca64f2fe145909f31af266b1730874051ba76c78
Flags: needinfo?(anshulj)

Comment 17

4 years ago
Anshul,

Please respond to Walter's questions re: SIM Network in comment 14.

(In reply to Walter Chen[:ypwalter][:wachen] from comment #14)
>
> ...
> 
> Tried different ways of dialing and none of them are working. The message is
> showing some kind of error related with cost control. Is it possible that it
> is something about voice call by a specific SIM card with 3G/3.5G/4G network
> on? Can you tell us more about sim data/voice plan and its service provider?

Thanks,
Mike
Flags: needinfo?(anshulj)
Reporter

Comment 18

4 years ago
I am using ATT SIM card with 3G capabilities. Although I have data turned off during my testing.
Flags: needinfo?(anshulj)
NI, walter can we try this again ? Tim Would more logs from CAF help here ?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(wachen)
Flags: needinfo?(timdream)
As I said, I don't think any reproducible steps before comment 11 are the same. We are not specifically find out what is being regarded as blocker here.

(In reply to Anshul from comment #0)
> The exception seems to be coming from
> http://lxr.mozilla.org/gaia/source/shared/js/dump.js#24

The only way this line could throw would be if the System app is not receiving mozSettings permission, in which I highly doubt is possible.
Flags: needinfo?(timdream)
still per comment 14, I am not able to reproduce it here. We don't have AT&T here. We need a QA in USA to retry this one more time if this issue is reproducible with AT&T card. There is not much I can do here.
Flags: needinfo?(wachen)

Updated

4 years ago

Updated

4 years ago
No longer blocks: CAF-v3.0-FL-metabug

Comment 22

4 years ago
Bhavana,

Per Walter's comment 21, can you have someone on our US QA team help with this?

Thanks,
Mike
Flags: needinfo?(bbajaj)
Definitely, NI :ktucker to take care of this.
Flags: needinfo?(bbajaj) → needinfo?(ktucker)
Keywords: qawanted
I cannot reproduce this issue following steps at comment 8. It is unclear in those steps on which device is making a call and which is receiving a call, so I tried a few scenarios but none of them reproduced the issue.

I'm using AT&T SIM with 3G capabilities but data is turned off during testing.

Tested on:
Device: Flame 2.2 (Full flashed 319MB mem)
BuildID: 20150313002507
Gaia: 4aefc3f6f30a40ac67fdf841b7c90cd648b85369
Gecko: 049713f3b0ed
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted
Flags: needinfo?(nhirata.bugzilla)
Reporter

Comment 25

4 years ago
I think we have a temporary solution to this problem by adding some delays in our test script. That may be good enough for now since Mozilla can not reproduce the issue.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Posted file logcat.txt
adb forward tcp:2828 tcp:2828 && gaiatest --testvars=/Volumes/Projects/testvars/testvars.json --address=localhost:2828 --timeout=20000 --type=B2G /Volumes/Projects/gaia_master/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_dialer.py --repeat=3

with the modification of the testvars file to contain the a real number for the remote phone number and modification of the test_dialer.py script to have pauses [ import time and time.sleep(10) at the end of the test ] 

I then hung up the phone twice on the other device and then picked up and hung up the third.  (the other phone wasn't automated )
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.