[Window Management] Double tapping the power button while camera is in card view causes no icons to appear on the homescreen

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: etienne)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-2] [systemsfe], URL)

Attachments

(2 attachments)

Posted file logcat.txt
If the user goes into card view while in the "Camera" app and then double taps the power button, no icons will appear on the homescreen. The user will have to restart their device to recover.

Repro Steps:
1)  Updated Flame to Build ID: 20141215040201
2)  Open the camera app.
3)  Hold down the "Home" button to enter card view and immediately double tap the power button. (This appears to be a timing issue)

Actual:
The user will be on a homescreen that has no app icons present. They will have to restart their device to recover.

Expected:
All app icons appear as expected on the homescreen.

Environmental Variables
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141215040201
Gaia: e2a3e606675c346b6e6f35351a458040be599b09
Gecko: f14dcd1c8c0b
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Notes:
Repro frequency: 5/5 100%
See attached: video,logcat
The user can still access the power menu after encountering this issue.
This issue does not occur on the Flame 2.1

The user always has the expected app icons on the homescreen after double tapping the power button while in camera card view.

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141215001202
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: ec87f4f41d3d
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Nominating this to block 2.2. This bug is easy to reproduce, and requires the user to completely restart their device after it occurs. Also a regression.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
blocking-b2g: --- → 2.2?
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140913094607
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: f6a8ea81fa4e
Platform Version: 35.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken
BuildID: 20140913101006
Gaia: e5da0e462e51cf7f56963e87deb845f87a3a1cf4
Gecko: d070787de8f7
Platform Version: 35.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Working Gaia / Broken Gecko = No repro
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: d070787de8f7
Broken Gaia / Working Gecko = Repro
Gaia: e5da0e462e51cf7f56963e87deb845f87a3a1cf4
Gecko: f6a8ea81fa4e
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/b72909030e214175144342f7e5df7e88a2b52fd4...e5da0e462e51cf7f56963e87deb845f87a3a1cf4


B2G Inbound
Last working
BuildID: 20140912033253
Gaia: 01f134698b932b0ffbdfa7ec658b5cd5e9b5634b
Gecko: 0d192e937f86
Platform Version: 35.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken
BuildID: 20140912034752
Gaia: 3d80e3c4598c6004bf29fc9189c9644d2186156f
Gecko: 76c10ad981c9
Platform Version: 35.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Working Gaia / Broken Gecko = No repro
Gaia: 01f134698b932b0ffbdfa7ec658b5cd5e9b5634b
Gecko: 76c10ad981c9
Broken Gaia / Working Gecko = Repro
Gaia: 3d80e3c4598c6004bf29fc9189c9644d2186156f
Gecko: 0d192e937f86
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/01f134698b932b0ffbdfa7ec658b5cd5e9b5634b...3d80e3c4598c6004bf29fc9189c9644d2186156f
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
caused by the patch to 	Bug 1061324 - can you take a look Etienne?
Blocks: 1061324
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(etienne)
QA Contact: ckreinbring
(Assignee)

Comment 5

4 years ago
(In reply to Joshua Mitchell [:Joshua_M] from comment #4)
> caused by the patch to 	Bug 1061324 - can you take a look Etienne?

On it.
(Assignee)

Comment 7

4 years ago
Hi, can you test again with this patch? Since the timing is important I want to double check that this is indeed fixing the issue. Thanks!
Flags: needinfo?(etienne) → needinfo?(ktucker)
Issue is fixed with the patch "bug-1111871" implemented. 

Actual Results: Homescreen icons remain after Camera is opened, then locked, then unlocked quickly. 

Note: This issue appears to be fixed with the patch.  However, the device will transition to cardview after the lock button is pushed. If user then taps the display here, the lockscreen will appear. 

Device: Flame 2.2
BuildID: 20141217035735
Gaia: 88d5986e252706237dac59a9af75c30a66476e98
Gecko: cb8ad2251c09
Version: 37.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8537874 [details] [review]
[PullReq] etiennesegonzac:bug-1111871 to mozilla-b2g:master

Ready for review then :)
Attachment #8537874 - Flags: review?(sfoster)
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
Comment on attachment 8537874 [details] [review]
[PullReq] etiennesegonzac:bug-1111871 to mozilla-b2g:master

Looks good. Also checked we didn't regress bug 804398. 
(Note for QA, the STR should include turning on lockscreen in Settings)
Attachment #8537874 - Flags: review?(sfoster) → review+

Updated

4 years ago
Whiteboard: [2.2-exploratory-2] → [2.2-exploratory-2] [systemsfe]
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
(Assignee)

Comment 13

4 years ago
Comment on attachment 8537874 [details] [review]
[PullReq] etiennesegonzac:bug-1111871 to mozilla-b2g:master

(autolander stuff)
Attachment #8537874 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#rlzmU67KRHSE1q0AsRlx0g

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+

Comment 16

4 years ago
Verified the issue is fixed on Flame 2.2

The homescreen icons doesn't disappear when tapping the power button twice after opening the "Camera" app in "card" view

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222040204
Gaia: ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko: b915a50bc6be
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.