[v2.2] Investigate intermittent failure in test_sms_with_picture_attached.py and test_add_photo_to_contact.py

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
test_sms_with_picture_attached has been failing intermittently on Jenkins with the following error:

Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.5-py2.7.egg/marionette/marionette_test.py", line 267, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_sms_with_picture_attached.py", line 54, in test_sms_cropped_picture
crop_view.tap_crop_done()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/crop_view.py", line 28, in tap_crop_done
self.marionette.find_element(*self._crop_done_button_locator).tap()
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.5-py2.7.egg/marionette/marionette.py", line 89, in tap
return self.marionette._send_message('singleTap', 'ok', id=self.id, x=x, y=y)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.5-py2.7.egg/marionette/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/jenkins/1/workspace/flame-kk-319.mozilla-central.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.5-py2.7.egg/marionette/marionette.py", line 611, in _send_message
"Connection timed out", status=errors.ErrorCodes.TIMEOUT)
TimeoutException: TimeoutException: Connection timed out


Most recent errors/exceptions are:
12-15 17:50:06.567 W/SocketClient( 196): write error (Broken pipe)12-15 18:29:29.250 W/SocketClient( 196): write error (Broken pipe)12-15 18:53:07.688 W/GeckoConsole(30187): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]12-15 18:54:25.838 W/GeckoConsole(30187): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]12-15 18:54:27.298 W/GeckoConsole(30187): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 103}]
The B2G process has restarted after crashing during the tests so Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/197/HTML_Report/

Build info Flame v2.2:
Device firmware (base) 	L1TC10011880
Device firmware (date) 	15 Dec 2014 16:29:35
Device firmware (incremental) 	eng.cltbld.20141215.192924
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	15 Dec 2014 04:31:03
Gaia revision 	c5b01c018e79
Gecko build 	20141215160201
Gecko revision 	5d6e0d038f95
Gecko version 	37.0a1

I will investigate this issue further.
Assignee

Updated

5 years ago
QA Whiteboard: [fxosqa-auto-s6+]
Assignee

Updated

5 years ago
See Also: → 1109213
Assignee

Comment 1

5 years ago
This issue cannot be reproduced manually and the failure looks similar to the one from Bug 1109213.

Preconditions: Must have one image in gallery
STR from the test:
1. open Messages app
2. tap create new message
3. type phone number and message (I do not believe this is necessary to reproduce the failure)
4. tap attachment
5. tap gallery
6. tap on first thumbnail
7. tap done
Assignee

Updated

5 years ago
QA Whiteboard: [fxosqa-auto-s6+] → [fxosqa-auto-from-s6] [fxosqa-auto-s7]
Test test_add_photo_to_contact.py is failing intermittently on v2.2 at the same step test_sms_with_picture_attached.pt is failing: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.smoke/241/HTML_Report/

Device firmware (base) 	L1TC10011880
Device firmware (date) 	06 Jan 2015 01:34:26
Device firmware (incremental) 	eng.cltbld.20150106.043413
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	05 Jan 2015 11:31:35
Gaia revision 	b77e0d56d197
Gecko build 	20150106010234
Gecko revision 	2a193b7f395c
Gecko version 	37.0a1

After selecting the first thumbnail from gallery and tapping Done button in Crop View, edit contact page is displayed and the device gets stuck. I added a 3 sec sleep before tap on Done button, and the test passed 15/15 times.   
That means we might find a wait instead of the sleep and fix the tests. Also test the fix to work for both tests, as they seem to fail for the same reason.
Summary: [v2.2] Investigate test_sms_with_picture_attached intermittent failure → [v2.2] Investigate intermittent failure in test_sms_with_picture_attached.py and test_add_photo_to_contact.py
Assignee

Updated

5 years ago
QA Whiteboard: [fxosqa-auto-from-s6] [fxosqa-auto-s7] → [fxosqa-auto-from-s6] [fxosqa-auto-from-s7] [fxosqa-auto-s8]
Assignee

Comment 3

5 years ago
Attachment #8553713 - Flags: review?(viorela.ioia)
Attachment #8553713 - Flags: review?(florin.strugariu)
Attachment #8553713 - Flags: review?(florin.strugariu) → review-
Assignee

Comment 4

5 years ago
Comment on attachment 8553713 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27632

Added comment for the hardcoded sleep.
Attachment #8553713 - Flags: review- → review?(florin.strugariu)
Assignee

Updated

5 years ago
QA Whiteboard: [fxosqa-auto-from-s6] [fxosqa-auto-from-s7] [fxosqa-auto-s8] → [fxosqa-auto-from-s6] [fxosqa-auto-from-s7] [fxosqa-auto-from-s8] [fxosqa-auto-s9]
Comment on attachment 8553713 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27632

restarted the addhoc

Let's see how it runs
Comment on attachment 8553713 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27632

r+, the adhoc I started is green: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/652/console
Looks like the sleep fixes the issue
Attachment #8553713 - Flags: review?(viorela.ioia) → review+
Attachment #8553713 - Flags: review?(florin.strugariu) → review+
You need to log in before you can comment on or make changes to this bug.