Closed Bug 1111995 Opened 5 years ago Closed 5 years ago

border-radius does not change hover zone for input/button elements

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: tj, Assigned: mats)

References

Details

(Keywords: css3, testcase)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Create circular button using input(submit) or button element with border-radius:
<button style="width:100px; height:100px; border-radius:50%;">Round button</button>
You can add hover style on button for better visual understanding.


Actual results:

Clicking on corner (of bound box) where no visual element and you are clicking on button, but visual you click on background.


Expected results:

Click should go through rounded corner and not hit button.
Keywords: css3
OS: Windows 8.1 → Windows 7
Assignee: nobody → mats
Component: CSS Parsing and Computation → Layout: Form Controls
Keywords: testcase
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 34 Branch → unspecified
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch fixSplinter Review
Attachment #8538006 - Flags: review?(roc)
I retriggered the test ~50 times on non-B2G platforms and they were all green,
so it seems to be a B2G issue.  The changed code is cross-platform.
So I disabled the test on B2G for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/542e2960e4d0
https://hg.mozilla.org/integration/mozilla-inbound/rev/a2f90950d072
https://hg.mozilla.org/mozilla-central/rev/542e2960e4d0
https://hg.mozilla.org/mozilla-central/rev/a2f90950d072
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Depends on: 1529036
You need to log in before you can comment on or make changes to this bug.