Closed Bug 1112230 Opened 5 years ago Closed 5 years ago

Find in page: Case insensitivity toolbar button no reacting to every touch event/tapping

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 37
Tracking Status
fennec + ---

People

(Reporter: aryx, Assigned: capella)

References

Details

Attachments

(1 file)

Firefox for Android Nightly 2014-12-16

The icon to disable case sensitivity in the "Find in page" toolbar doesn't react to every touch event, only some. So I have to tap it sometimes 4-6 times until the state toggles.
tracking-fennec: --- → ?
Hey mark, can you look at this?
Assignee: nobody → markcapella
Status: NEW → ASSIGNED
No longer blocks: 1112232
tracking-fennec: ? → +
Attached patch bug1112230.diffSplinter Review
The responsive area for the CheckedTextView is the actual text chars 'Aa' ... tapping somewhat near isn't good enough to trigger action ...

Expanding the internal padding widens the hit box ... pushing to try for archaeopteryx to check ...

https://tbpl.mozilla.org/?tree=Try&rev=d320d70c5fca
Attachment #8539399 - Flags: feedback?(archaeopteryx)
Comment on attachment 8539399 [details] [diff] [review]
bug1112230.diff

Review of attachment 8539399 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you. After installing the opt build on a Nexus S with Android 4.1.2 stock image, the toggling of the case insensitivity works without issues. The phone rebooted when I loaded a page, but this should be unrelated to this patch and I couldn't reproduce the issue.
Attachment #8539399 - Flags: feedback?(archaeopteryx) → feedback+
Attachment #8539399 - Flags: review?(wjohnston)
Attachment #8539399 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/48b7608267e9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
You need to log in before you can comment on or make changes to this bug.