[Contacts][ICE] Deleting 2 ice contacts, then creating a new contact cause ICE symbol to appear on contacts list

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rmead, Assigned: arcturus)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-2], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted file Flame2.2logcat.txt
Description:
If the user creates 2 contacts and sets them as ICE, then deletes both contacts the ICE symbol will disappear as it should from the contacts list. If the user then creates another contact, the ICE symbol will appear again, even though it is empty and no ICE are set.

Prereq:
Have 2 contacts created with a phone number attached

Repro Steps:
1) Update a Flame to 20141216040205
2) Tap 'Contacts' app
3) Tap Settings icon in upper right corner
4) Tap 'Set ICE Contacts' and choose both the contacts you created
5) Once both contacts are set, tap the back arrow and select 'Done'
6) Tap Settings icon again
7) Tap 'Delete Contacts'> Tap Select all > Then tap delete
8) Confirm and tap red 'Delete' button(ICE Contact icon should be gone now)
9) Tap Plus icon to add a new contact
10) Add a name and number, tap Done, and observe


Actual:
The ICE symbol will appear again. If you tap it, you'll be brought to a page with no contacts.


Expected:
The ICE symbol should not appear again until new ICE contacts are set.


Environmental Variables:
Device: Flame 2.2(319mb)(KitKat)(Full Flash)
Build ID: 20141216040205
Gaia: af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko: a3030140d5df
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Notes: This issue will keep happening, even if you restart the device. Only way to clear it is to factory reset.


Repro frequency: 100%
See attached: logcat, video - http://youtu.be/x98ZSC6KAj8
(Reporter)

Comment 1

4 years ago
This issue does NOT occur on Flame 2.1

When the ice contacts are deleted, and a new contact is created, the ice icon will not appear.

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141216001202
Gaia: 79286eafe67707d1330966c1b1413b2d0de595d9
Gecko: 222a62b532db
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0



The ICE feature was not available on the Flame 2.0(319mb)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

The user will see a blank page where the ICE contacts should be. This is a confusing end user experience, and a regression. Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: jmitchell
Regression window unavailable - this issue occurs in first 2.2 KK build

Device: Flame 2.2
Build ID: 20140904171737
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: 8703c1895505
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: jmitchell
triage: regression
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → francisco
Attachment #8537831 - Flags: review?(sergi.mansilla)
Comment on attachment 8537831 [details] [review]
[PullReq] arcturus:bug-1112254 to mozilla-b2g:master

Good job Francisco!
Attachment #8537831 - Flags: review?(sergi.mansilla) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/b7ce1dbbbcee9299c354b600fb237fe1ae28efdc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 8

4 years ago
Verified the issue is fixed on Flame 2.2

A new created contact is not appears as ICE contact with the ICE icon, after ICE contacts were previously deleted

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222040204
Gaia: ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko: b915a50bc6be
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.