posten.se - dynamic menus don't work in Mozilla and Netscape 6

VERIFIED FIXED in Dec

Status

Tech Evangelism Graveyard
Other
P2
normal
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Per Ångström, Assigned: Tristan Nitot)

Tracking

unspecified

Details

(Whiteboard: [PROPRIETARY-DOM], URL)

(Reporter)

Description

16 years ago
The website for Posten.se, the Swedish Mail, doesn't work very well with Mozilla
and Netscape 6; the dynamic menus don't work, which makes a lot of functionality
unavailable.

Here is just one example: On the page
<URL:http://www.posten.se/privat/index.jsp>, a menu should drop down when you
click the bar labelled "Meny", but that doesn't happen.

In the file <URL:http://www.posten.se/js/menuPrivat.js> we can see that the
browser detection is very crude:
>ns = document.layers;
>ie = document.all;

BTW, they also have a Y2K problem in Mozilla, which can be seen on the page
<URL:http://hitta.posten.se/>.

When I contacted them, they said they are working on supporting "Netscape", but
it was a very vague statement, and maybe they can need some help.

Comment 1

16 years ago
Yeah they sniff us bad.  the variables 'ns' and 'ie' both get set to undefined
which return false since we don't do document.layers or document.all.

The Y2K problem is because they use getYear() instead of getFullYear(). 
getYear() returns the current year minus 1900, which is 101.  getFullYear()
obviously returns 2001.  They try to accomodate for it by saying 
if(ns) {
  if(year < 2000) {
    year += 1900
  }
}

but since they sniff us incorrectly, that code obviously doesn't work.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [PROPRIETARY-DOM]
(Assignee)

Comment 2

16 years ago
Per : can you tell us who you have contacted, and how ? I could re-use this
information. Thanks.

Confirming on Moz 096 Win2K. 

Contact info : kundtjanst@posten.se 
Phone : +46 8 23 22 21 
Setting P2.
Sent Web Evang letter. Accepting bug.
Status: NEW → ASSIGNED
Priority: -- → P2
(Assignee)

Comment 3

16 years ago
Setting target to December.
Target Milestone: --- → Dec
(Reporter)

Comment 4

16 years ago
I have been in e-mail contact with two people at Posten's Customer Services, in
 response to the messages I have sent to <mailto:webmaster@posten.se>. I suspect
that these people are intermediaries without direct decision power. Therefore, I
will not give out their names in this public forum, although I can do so in
private correspondance. 

However, I have found an e-mail address that may be of interest:
<mailto:Webbgrupp@posten.se>. I have no names of people working in that group.
(Assignee)

Comment 5

16 years ago
re-sent mesage to lena.hultberg@posten.se
Another copy to Webbgrupp@posten.se.

Updated

16 years ago
Blocks: 113492

Updated

16 years ago
No longer blocks: 113492

Comment 6

16 years ago
The entire site has been redesigned, and now the new menus work perfectly. A
quick browse on the site also indicates that it works overall very well with
Mozilla.

Per, please resolve if you agree that the menus are fixed.
(Reporter)

Comment 7

16 years ago
With pleasure, I hereby resolve the bug as FIXED. Actually, the DHTML is gone,
which in my opinion was the best possible fix they could come up with. Bravo!
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.