[sms] Thread list header "Messages" font size too small

RESOLVED DUPLICATE of bug 1112131

Status

RESOLVED DUPLICATE of bug 1112131
4 years ago
4 years ago

People

(Reporter: mikehenrty, Assigned: awalgarg, Mentored)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [sms-papercuts][lang=js][good first bug])

Attachments

(1 attachment)

Created attachment 8538040 [details]
[screenshot] tiny "messages"
Maybe it will be fixed by bug 1089920, but let's have a blocking status so that we don't lose it in case it's not.
blocking-b2g: --- → 2.2?
Triage: Visible regression.
blocking-b2g: 2.2? → 2.2+
What's funny is that I don't see this on my Buri or my Flame with a current master :)

QA, can you please test this, and possibly find a STR for this? Or does it happen only sometimes?
Keywords: qawanted
Adding steps wanted as we don't currently have STRs.
Keywords: steps-wanted
This is a Full vs Shallow flash issue.

Shallow flashing the Flame device, I get this small text every time in both User Nightly and Engineering builds. However If I full flash a user nightly build then the Messages header is correct size.

Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.2 KK, Flame 2.1 KK

Actual Results: Small Messages header seen when shallow flashing in the the branches below.

Repro Rate: 4/4

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141223065136
Gaia: 0db8a38f9fed18ae2abf5ef7e1b6e2a570b07e0e
Gecko: bc71b49d9bf8
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141222071650
Gaia: 1a58335917b23c170d85bf821f658e964c935b23
Gecko: 5509822354a9
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0 KK, Flame v188-1 Base

Actual Result: Correct Size Messages header when shallow flashing.

Repro Rate: 0/2

Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141222071429
Gaia: ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko: 7d0adaf6c447
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame v188-1 Base
BuildID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted, steps-wanted → regression
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
Michael - do you know if you were Shallow flashing when you saw this issue?

If so - might be a dupe of (or a see-also) bug 1069495
Flags: needinfo?(mhenretty)
Yup, I definitely shallow flash.
Flags: needinfo?(mhenretty)
At least I think it's not a blocker anymore, let's renominate.

On my Buri I use the correct fonts and I don't see the issue.

I don't really understand why having bad fonts would trigger this issue though, unless we calculate using some fonts and display using other fonts?
blocking-b2g: 2.2+ → 2.2?
Would be useful to know if you have the issue when first full flashing (and thus getting the right fonts), and then shallow flashing.

Thanks!
Keywords: qawanted
Per comment 8 I agree this is not a blocker given the STR is not a usual case for end user.
(In reply to Julien Wajsberg [:julienw] (PTO 12/25 -> 12/29) from comment #8)
> I don't really understand why having bad fonts would trigger this issue
> though, unless we calculate using some fonts and display using other fonts?

We calculate the font using getComputedStyle for the header element. But perhaps if we don't have the right font installed, we get `unknown` here [1], which should mess up all font fit calculations and not just thread list.

1.) https://github.com/mozilla-b2g/gaia/blob/3042a3d27ccc5ed2ea7e40a33769369d797b06c3/shared/elements/gaia-header/lib/font-fit.js#L223
Right, maybe replacing "unknown" by "sans-serif" would be a good idea?
(In reply to Julien Wajsberg [:julienw] (PTO 12/25 -> 12/29) from comment #9)
> Would be useful to know if you have the issue when first full flashing (and
> thus getting the right fonts), and then shallow flashing.
> 
> Thanks!

Julien,

After Basing then full flashing (verify correct size) then shallow flashing, I found the font size to retain correct behavior. This was seen on the 12/29 Nightly build.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base
Build ID: 20141229010215
Gaia: bdedbaf9f18a43c091ede770407d68d38582fe29
Gecko: 8850aa0f5332
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
(In reply to Julien Wajsberg [:julienw] (PTO 12/25 -> 12/29) from comment #12)
> Right, maybe replacing "unknown" by "sans-serif" would be a good idea?

Worth a try.
Moving to Gaia::Component, we'll land the simple change outlined in comment 12 here.
Component: Gaia::SMS → Gaia::Components
Mentor: felash
Whiteboard: [sms-papercuts] → [sms-papercuts][lang=js][good first bug]
To a contributor: we want to change the code in [1]: replace 'unknown' by 'sans-serif'. You'll need to update the unit tests if this makes sense (I'm not sure it does).

[1] https://github.com/gaia-components/gaia-header/blob/2fffa7fcfb842399fcce5cc9d915988ddc901269/lib/font-fit.js#L230
(Assignee)

Comment 17

4 years ago
Hi there,

I am new here, and I would like to take this as my first bug :) I have created the initial commit with the PR here: https://github.com/gaia-components/gaia-header/pull/17

awalGarg
Hi, awalgarg, thanks, looks good !

Can you try to add a test in test/font_fit_test.js ?
I don't see how to do it otherwise than calling directly _getStyleProperties with a heading having a bogus fontFamily. If this don't work, please keep it in the pull request and ask me so that I can have a look :)

You have information about how to run tests in [1].

In case you use Linux, I personally need to add "FIREFOX_NIGHTLY_BIN=/path/to/firefox" before "npm test" so that it correctly picks up my Firefox Nightly, but if you use MacOS X I think it works automatically.

[1] https://github.com/gaia-components/gaia-header/#tests

Thanks !
Assignee: nobody → aakarsh1997
(Assignee)

Comment 19

4 years ago
Hi Julien,

I would add a test in a while. Yep, I am using Linux, I would keep that in mind.

Thanks for the guidance!

awalGarg
Status: NEW → ASSIGNED
(Assignee)

Comment 20

4 years ago
Hi Julien,

Sorry I am too late... I have added two tests. Kindly review here: https://github.com/gaia-components/gaia-header/pull/17

Thanks

awalGarg
The patch in bug 1112131 will change a lot how the gaia-header component works and it should fix this issue as well.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112131
removing the nom as it's dup is already set as blocking-b2g:2.2+.
blocking-b2g: 2.2? → -
You need to log in before you can comment on or make changes to this bug.