[Internet Sharing] Unable to enable USB Tethering when Wi-Fi is connected.

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ychung, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-exploratory-2], )

Attachments

(2 attachments)

Reporter

Description

5 years ago
Description:
When the device is connected to a Wi-Fi network and the user enables the data connection,  the user is unable to enable USB Tethering. An error message is displayed instead.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141217040204
2) Settings > Wi-Fi > Connect to a network. 
3) Settings > Cellular & Data > Enable Data Connection.
4) Settings > Internet Sharing > Enable USB Tethering.
  
Actual:
An error message is displayed, and USB Tethering is not enabled:
"No data connection
USB tethering is disabled because there is no data connection."
  
Expected: 
USB Tethering is enabled correctly.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141217040204
Gaia: d22dfece04fc00457e8369c660c11f945b088d2f
Gecko: cb8ad2251c09
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
   
Repro frequency: 100%,
See attached: video clip, logcat
http://youtu.be/1nB5jr1BsCI
Reporter

Comment 1

5 years ago
This issue does NOT reproduce on Flame 2.1.

Result: USB Tethering is enabled properly.

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141217001201
Gaia: 14315733e2d265a42f9ab02d1aba191789870f70
Gecko: ddecea83ce6e
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

The wifi is not properly being disabled when turning tethering on. This is confusing UX, and a regression. Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)

Comment 3

5 years ago
Hi Arthur, can you help to check the behavior? thanks
Flags: needinfo?(arthur.chen)
Regression window
Last working
BuildID: 20141024070214
Gaia: 29ed78a26d62b58f663437a45f273d57b9781d79
Gecko: d6abb9bf43be
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141024143612
Gaia: bd7a73c1f1d8211deb95543e9e14a5eeef36d5e1
Gecko: 7fc54253717b
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 29ed78a26d62b58f663437a45f273d57b9781d79
Gecko: 7fc54253717b
Broken Gaia / Working Gecko = Repro
Gaia: bd7a73c1f1d8211deb95543e9e14a5eeef36d5e1
Gecko: d6abb9bf43be
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/29ed78a26d62b58f663437a45f273d57b9781d79...bd7a73c1f1d8211deb95543e9e14a5eeef36d5e1


B2G Inbound
Last working
BuildID: 20141024064511
Gaia: a1f65277782e77f3d03be5d93fb1359c63ad6fac
Gecko: afe016d0062d
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141024065809
Gaia: 93292c51ac424e94373dff209bbd1b8661bebede
Gecko: 25eab25a9fcf
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: a1f65277782e77f3d03be5d93fb1359c63ad6fac
Gecko: 25eab25a9fcf
Broken Gaia / Working Gecko = Repro
Gaia: 93292c51ac424e94373dff209bbd1b8661bebede
Gecko: afe016d0062d
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/a1f65277782e77f3d03be5d93fb1359c63ad6fac...93292c51ac424e94373dff209bbd1b8661bebede
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: ckreinbring
looking at this pushlog it seems this bug is possibly caused by the patch from  Bug 1026306
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(b.mcb)
QA Contact: ckreinbring
Could be an invalid bug, Arthur to confirm.
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
USB tethering should be enabled correctly as long as usb storage is disabled. It has nothing to do with the current connecting status. This issue could be fixed by removing the check of the status.
Flags: needinfo?(arthur.chen)
Posted file WIP
The current behavior is from these two comments[1][2], but the conclusion there seems only apply to wifi hotspot but not usb tethering.

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=868902#c21
[2]: https://bugzilla.mozilla.org/show_bug.cgi?id=868902#c23

Jenny, could you help confirm the behavior?
Flags: needinfo?(jelee)

Comment 9

5 years ago
Triage: blocking as feature broken.
blocking-b2g: 2.2? → 2.2+

Comment 10

5 years ago
Hi Arthur,

Per discussion, I'm inclined to make change as you suggested when v3 planning is more settled. Thanks for understanding :)!
Flags: needinfo?(jelee)
Comment on attachment 8541091 [details]
WIP

Per the offline discussion with Jenny, whether we can enable wifi hotspot or not only depends on the status of airplane mode. In this patch I simply removed all checks except for the one of airplane mode, could you help check it? Thanks!
Attachment #8541091 - Flags: review?(alive)
Comment on attachment 8541091 [details]
WIP

r=me
Attachment #8541091 - Flags: review?(alive) → review+
master: 8f7f71aeb727dbf728988a1ac9d5f1055d903dea
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(b.mcb)
Resolution: --- → FIXED
Comment on attachment 8541091 [details]
WIP

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1026306
[User impact] if declined: Users are not able to do tethering when both data connection and wifi are enabled.
[Testing completed]: Manual test completed.
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: Unused strings were removed. No strings added.
Attachment #8541091 - Flags: approval-gaia-v2.2?
Keywords: verifyme
Flags: needinfo?(ychung)
Attachment #8541091 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 15

5 years ago
This issue is verified fixed on Flame Master.

Result: USB tethering works properly when both Wi-Fi and data connection are enabled. 

Environmental Variables:
Device: Flame Master (319mb, full flash)
BuildID: 20150120010227
Gaia: a5c5ac093814a80b0627514c3bd5f9e96c096a4b
Gecko: c1c6840d9255
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
Keywords: verifyme
Yeojin, please verify this on 2.2 tomorrow.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(ychung)
Reporter

Comment 18

5 years ago
This issue is verified fixed on Flame 2.2.

Result: USB tethering works properly when both Wi-Fi and data connection are enabled. 

Environmental Variables:
Device: Flame 2.2 (319mb, full flash)
BuildID: 20150121002607
Gaia: e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko: 75a462a58d7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.