[RTL][Calendar] Drawer tray and Calendar Settings do not have UI elements properly aligned/mirrored

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: bzumwalt, Assigned: nefzaoui)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-exploratory-2])

Attachments

(4 attachments)

Posted image Screenshot
Description:
In Calendar when language is RTL like Arabic, subheaders in options menu are not right-aligned, and the blue checkmark icons as well as the text in drawer tray keep alignment from LTR language format. 

According to spec, the subheaders and text should be right aligned and the blue checkmarks should be left aligned.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141217040204
2) Set language to Arabic
3) Launch Calendar
4) Tap drawer icon and observe open tray
5) Tap gear icon and observe settings screen
  
Actual:
Subheaders and text in drawer and settings menu are left aligned. Checkboxes in drawer are right aligned.
  
Expected: 
Subheaders and text in drawer and settings menu are right aligned. Checkboxes in drawer are left aligned.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141217040204
Gaia: d22dfece04fc00457e8369c660c11f945b088d2f
Gecko: cb8ad2251c09
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 3/3, 100%
See attached: screenshot
QA Whiteboard: [rtl-impact]
Flags: needinfo?(dharris)
QA Whiteboard: [rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Whiteboard: [2.2-exploratory-2]
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
Comment on attachment 8547222 [details] [review]
[PullReq] anefzaoui:bug-1112908 to mozilla-b2g:master

Please review?
Thanks!
Attachment #8547222 - Flags: review?(mmedeiros)
Assignee: nobody → nefzaoui
Status: NEW → ASSIGNED
Comment on attachment 8547222 [details] [review]
[PullReq] anefzaoui:bug-1112908 to mozilla-b2g:master

LGTM. fixes the problem. thanks!
Attachment #8547222 - Flags: review?(mmedeiros) → review+
https://github.com/mozilla-b2g/gaia/pull/27302

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Keywords: verifyme
Hi Ahmend:
This issue still exist on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate 5/5
Happen time   2:10
Description:Launch calendar->Tap drawer icon and observe open tray->Tap gear icon and observe settings screen,Subheaders and text in drawer and settings menu are left aligned. Checkboxes in drawer are right aligned.
Expected: 
Subheaders and text in drawer and settings menu are right aligned. Checkboxes in drawer are left aligned.
Pleaser refer to viedo VIDEO0253.mp4 and logcat.txt
Status: RESOLVED → REOPENED
Flags: needinfo?(nefzaoui)
Keywords: verifyme
Resolution: FIXED → ---
Posted file logcat.txt
Posted video VIDEO0253.mp4
I'm aware of this, and it will be handled by an uplifting request.
Flags: needinfo?(nefzaoui)
Verified the fix on Flame Master (currently 3.0) and looks good.
Nominating for 2.2 as this needs to be consistent across the phone.
blocking-b2g: --- → 2.2?
Priority: -- → P1
Comment on attachment 8547222 [details] [review]
[PullReq] anefzaoui:bug-1112908 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): lack of RTL support
[User impact] if declined: see attachment 8538163 [details]
[Testing completed]: Yes, testing device: flame
[Risk to taking this patch] (and alternatives if risky): low risk, patch changes only rtl-related css
[String changes made]: No string changes
Attachment #8547222 - Flags: approval-gaia-v2.2?
Attachment #8547222 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
blocking-b2g: 2.2? → ---
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Uplifted to 2.2: https://github.com/mozilla-b2g/gaia/commit/6a0b6f6
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Please don't forget to set the status flags when uplifting.
Target Milestone: --- → 2.2 S4 (23jan)
Ooops, will do.
This issue is verified fixed on Flame 2.2 and Master.

Result: Menu items on the drawer and settings screen are right-aligned.
 
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame Master (319mb, full flash)
Build ID: 20150202010229
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: 940118b1adcd
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15240/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.