Roku Tab mirroring falls behind

RESOLVED INVALID

Status

()

Core
WebRTC
P2
normal
Rank:
27
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: blassey, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Using desktop firefox to mirror a playing youtube video to the roku, the video on the roku runs in slow motion until its about 10s behind, at which point it skips a bunch of frames to catch up and the process repeats.

Using the roku simulator, I don't see this issue.
I don't see this issue on my Roku 3. It is not smooth, but I never see it fall behind. I will try and set up the Roku Stick to see if it hardware related.
Also check the bandwidth used.   This sounds like some form of either over-bandwidth (packets arriving too slowly at Roku and it doesn't implement the bandwidth adaptation protocol used by webrtc - do you know if it does?) or a problem with processing the data at the Roku side fast enough (too-large frames for the HW decoder in the Roku).

I presume this is H.264.

Wireshark can monitor bandwidth in-use.  Also you can see the RTCP/etc data via turning on webrtc tracing (NSPR log webrtc_track:65535 with WEBRTC_TRACE_FILE=whatever, or use "turn on debug logs" in about:webrtc)
Needinfo myself to profile on the simulator and see if something inefficient is being done.
Flags: needinfo?(gpascutto)
tracking-fennec: ? → 36+
(In reply to Randell Jesup [:jesup] from comment #2)
> Also check the bandwidth used.   This sounds like some form of either
> over-bandwidth (packets arriving too slowly at Roku and it doesn't implement
> the bandwidth adaptation protocol used by webrtc - do you know if it does?)
> or a problem with processing the data at the Roku side fast enough
> (too-large frames for the HW decoder in the Roku).
> 
> I presume this is H.264.
> 

The Roku WebRTC player is currently using the VP8 software decoder as Roku has been waiting for Fennec to support H264 before starting work on adding H264 decoding to the player app.

I noticed that the Roku 3 is 300MHz faster than the stick (900 vs 600). At first I thought it might be due to a difference in available memory however the sticks we were given for development have 512MB just like the Roku 3. If this is caused by the slower clock speed, the Roku 1 and 2 will also have this problem. Hopefully moving to HW decode of H264 will alleviate this problem.
tracking-fennec: 36+ → +
backlog: --- → webRTC+
Rank: 27
Priority: -- → P2
Flags: needinfo?(gpascutto)
We are not shipping tab mirroring on roku, so I will close this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.