[ERROR] Internal error dispatching command “goto-url-newtab”. / [ERROR] TypeError: browserWin.content is null @<chrome://chatzilla/content/commands.js> 2234

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
critical
RESOLVED FIXED
3 years ago
10 months ago

People

(Reporter: njn, Assigned: Gijs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.91.1])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
I'm using the ChatZilla nightly from http://james-ross.co.uk/mozilla/chatzilla/nightly/builds/0.9.91/201412112314/chatzilla-0.9.91-201412112314.xpi. I get the following errors when I click on a link:

> [ERROR] Internal error dispatching command “goto-url-newtab”.
> [ERROR] TypeError: browserWin.content is null @ <chrome://chatzilla/content/commands.js> 2234

and the link doesn't open.
Is this with or without e10s?
Flags: needinfo?(n.nethercote)
This is e10s-only, I can reproduce.
Blocks: 905436
Flags: needinfo?(n.nethercote)
Created attachment 8538654 [details] [diff] [review]
fix content access in CZ,

This should do, I think.
Attachment #8538654 - Flags: review?(bugzilla-mozilla-20000923)
Assignee: rginda → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Created attachment 8538655 [details]
chatzilla-0.9.91.xpi

Here's an XPI that you can use which should work (wfm, at least).

As best I can tell this is the only use of window.content in CZ, so this should be the only other e10s fix we need (knock on wood).
(Reporter)

Comment 5

3 years ago
> Here's an XPI that you can use which should work (wfm, at least).

Works for me, too! Thank you for the quick fix.

Comment 6

3 years ago
Do we no longer need to retain backwards-compatibility for browser versions that don't have the gBrowser property?
(In reply to Glen Mailer from comment #6)
> Do we no longer need to retain backwards-compatibility for browser versions
> that don't have the gBrowser property?

... maybe? :-)

gBrowser predates the hg switch (in 2007) for Firefox. Don't know about seamonkey, but it's been in use there a while, too, AFAICT. Don't know what our explicit requirements are, I'll leave that to Silver.
Note also that this might break old songbird. I'm... not really bothered, I have to say.

Comment 9

3 years ago
Comment on attachment 8538654 [details] [diff] [review]
fix content access in CZ,

Review of attachment 8538654 [details] [diff] [review]:
-----------------------------------------------------------------

I'm happy if everything recent (last 6 months) works. We should kill the rest, especially including Songbird.
Attachment #8538654 - Flags: review?(bugzilla-mozilla-20000923) → review+
http://hg.mozilla.org/chatzilla/rev/5fbe9644bfae

Filed bug 1113707 to get rid of songbird compat.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED

Updated

10 months ago
Whiteboard: [cz-0.9.91.1]
You need to log in before you can comment on or make changes to this bug.