Closed Bug 111323 Opened 22 years ago Closed 22 years ago

Secure pages w/ https URLs don't render w/ 0.9.6/Linux


(Core Graveyard :: Installer: XPInstall Engine, defect)

Not set


(Not tracked)



(Reporter: acroyear, Assigned: asa)




This worked fine in 0.9.5.  Go to the URL specified.  Click "Online Branch",
which opens up an https:// url.  The page and the "M" of the upper left corner
of the browser blinks, but nothing else happens.  Hitting it with the middle
button brings up a blank page.

I can duplicate it as well with -- order something, click the button
for "Go To Secure Checkout" and the same thing happens, i.e., nothing at all.
Reporter: Have you installed a build with PSM or without ?
Have you a ssl tab under preferences/Privacy&Security/SSL ?
If not -> install a mozilla build with PSM (and this bug is invalid)
wfm using build 2001112111 on Linux.
i installed the same basic "talkback" binary release i installed for 0.9.5, 
0.9.4, 0.9.3, and 0.9.1.  those worked just fine for me (on this issue), as did 
a nightly from 3 days ago. if mozilla changed something so the "basic" first-
thing-you-see-on-the-downloads-page installation suddenly stopped shipping with 
https support which it had before, then i consider that a bug.

at the very least, if there's no support for https in a release/distribution
(For whatever reason) there should be some notification of that when the
user clicks an https link.  doing NOTHING is the absolute second worse thing
an application can do to a user input (crashing is the worst).  on a
useability standpoint, the current behaviour is still a bug.

but as i said, i just downloaded the basic binary from, just
as i always have since 0.9.1.  this is the first time this has happened, so
i consider it a bug until its explained to me otherwise.

however, i can't answer your question at this time, as i'm not at my office 
where my linux box is.
First we must know if you have installed PSM ....
You can disable PSM if you use the installer (AFAIK) and there are RPMs without PSM.
And we have also a bug about the notification if PSM is not installed and a
https link is opened.
To answer the question (now that I'm at work where my mozilla install is), no,
PSM is NOT in this install.  Again, I can't figure out what I did different.  I
just went through the normal install process, using "typical", just as I did for
0.9.5 and before.

I'm currently doing it again to see if anything changes...The specific
downloader I used was the "Linux x86 Talkback enabled Net Installer" this
second time, it seemed to work just fine, and I do have the SSL item in the
preference dialog's tree.  So something did go wrong in my first install, but it
seems to not be repeatable.
Doing a diff between the two installations showed this in the "broken" first

file:///home/jshelby/moz-tmp/mozilla-installer/./xpi/psm.xpi  --  11/21/2001

     Install **FAILED** with error -207
     Finished Installation  11/21/2001 10:45:09


Can you describe an error "-207" and what might have caused that?  Perhaps the
file didn't download that first attempt?
marking worksforme

Please send an email to if you want to know what the error means. is the component owner for Installer : XPI Packages

Thanks for your time and your retesting (and using mozilla) !

Closed: 22 years ago
Resolution: --- → WORKSFORME
Component: Browser-General → Installer: XPInstall Engine
Marking Verified as QA Contact for XPInstall.
QA Contact: doronr → jimmylee
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.