The text appears behind the image

RESOLVED FIXED in Firefox 36

Status

()

Core
Layout
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: smontagu)

Tracking

({regression, testcase})

36 Branch
mozilla37
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox35 unaffected, firefox36+ fixed, firefox37+ fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1105137 +++

The text appears behind the image in page https://dl.dropboxusercontent.com/u/95157096/85f61cf7/ItJnkL8E9x.html.

Screenshot https://dl.dropboxusercontent.com/u/95157096/85f61cf7/Qxj3jZf7uG.png.

Bug 1105137 does not fix the problem...
(Reporter)

Updated

3 years ago
Keywords: testcase-wanted
(Reporter)

Comment 1

3 years ago
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=506226a2e6c0&tochange=f1d7da5ff1ed

Last Good: 1de2c87f94e5
First Bad: 2a2316981708

Triggered by:
	2a2316981708	Simon Montagu — Bug 1062963 patch 3: make nsFloatManager's origin a LogicalPoint, adapt GetFlowAreas, AddFloats, ClearFloats, etc. to use it and make nsFloatManager region functions work with logical region. r=jfkthame

Comment 2

3 years ago
This also happens in https://dl.dropboxusercontent.com/u/95157096/85f61cf7/uidssg5u5s.html.

Screenshot https://dl.dropboxusercontent.com/u/95157096/85f61cf7/2sjkgf65kg.png

I think this happens if the picture within the frame.
(Reporter)

Comment 3

3 years ago
Created attachment 8539697 [details]
reduced testcase

STR
1. Load reduced testcase and reload
   ---- observe layout

2. Zoom In and then Zoom Out
   ---- observe layout

Actual Results:
Layout is broken at step 1.
layout is corrected at step 2, after reflow(ZoomIn/Out)
(Reporter)

Updated

3 years ago
Keywords: testcase-wanted → testcase
(Reporter)

Comment 4

3 years ago
Created attachment 8539703 [details]
reduced testcase
Attachment #8539697 - Attachment is obsolete: true
(Reporter)

Comment 5

3 years ago
[Tracking Requested - why for this release]: layout is broken due to regression of Bug 1062963
status-firefox35: --- → unaffected
status-firefox36: --- → affected
status-firefox37: --- → affected
tracking-firefox36: --- → ?
tracking-firefox37: --- → ?
Flags: needinfo?(smontagu)
(Assignee)

Comment 6

3 years ago
Created attachment 8540205 [details] [diff] [review]
Patch: make GetLogicalNormalPosition return the correct logical origin of the frame, not just convert the physical origin to logical coordinates
Assignee: nobody → smontagu
Flags: needinfo?(smontagu)
Attachment #8540205 - Flags: review?(jfkthame)
(Assignee)

Comment 7

3 years ago
Created attachment 8540208 [details] [diff] [review]
Reftest based on the testcase

I don't really understand this testcase, and it doesn't show the bug when loaded locally, so I'm not sure if I want to check it in, but here it is as a reftest so we can decide what to do with it. The test from bug 1114329 may be sufficient anyway.
Attachment #8540208 - Flags: feedback?(jfkthame)
(Assignee)

Updated

3 years ago
Blocks: 1114329
Comment on attachment 8540208 [details] [diff] [review]
Reftest based on the testcase

Review of attachment 8540208 [details] [diff] [review]:
-----------------------------------------------------------------

It looks like the wrong files ended up in this patch...

As for the testcase in this bug, note that it doesn't fail on initial load; you have to hit Reload to trigger the bad rendering. I'm not sure whether we'd be able to reproduce that behavior in the reftest framework, or if it'd need to be converted to a mochitest form.
Attachment #8540208 - Flags: feedback?(jfkthame) → feedback-
Important layout regression, tracking
tracking-firefox36: ? → +
tracking-firefox37: ? → +
Comment on attachment 8540205 [details] [diff] [review]
Patch: make GetLogicalNormalPosition return the correct logical origin of the frame, not just convert the physical origin to logical coordinates

Review of attachment 8540205 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense - and fixes the bug, according to local testing. :)
Attachment #8540205 - Flags: review?(jfkthame) → review+
(Assignee)

Updated

3 years ago
No longer blocks: 1114329
(Assignee)

Comment 11

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/bf55c6f6424d
https://hg.mozilla.org/integration/mozilla-inbound/rev/860181fd59cf

With the reftest from bug 1114329, since this patch fixes that test, but not the original problem reported in the bug.
Flags: in-testsuite+
OS: Windows 7 → All
Hardware: x86_64 → All
https://hg.mozilla.org/mozilla-central/rev/860181fd59cf
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox37: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla37

Updated

3 years ago
Duplicate of this bug: 1114332
Simon, can we have an uplift request for aurora? Thanks
Flags: needinfo?(smontagu)
(Assignee)

Comment 15

3 years ago
Comment on attachment 8540205 [details] [diff] [review]
Patch: make GetLogicalNormalPosition return the correct logical origin of the frame, not just convert the physical origin to logical coordinates

Approval Request Comment
[Feature/regressing bug #]: 1062963
[User impact if declined]: Elements in right-to-left pages can be invisible or mispositioned.
[Describe test coverage new/current, TBPL]: Baked on trunk since 2014-12-24, checkin includes regression test
[Risks and why]: Low risk one-line fix. Left-to-right pages will not be affected by the patch at all.
[String/UUID change made/needed]: None
Flags: needinfo?(smontagu)
Attachment #8540205 - Flags: approval-mozilla-aurora?
Comment on attachment 8540205 [details] [diff] [review]
Patch: make GetLogicalNormalPosition return the correct logical origin of the frame, not just convert the physical origin to logical coordinates

thanks!
Attachment #8540205 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

3 years ago
Depends on: 1142318
You need to log in before you can comment on or make changes to this bug.