Add 'x' to allow the user to remove the area that includes the Telefonica logo and links

RESOLVED WONTFIX

Status

Hello (Loop)
Client
P2
normal
Rank:
25
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: mreavy, Unassigned)

Tracking

unspecified
x86_64
Windows 7
Points:
1
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

There is currently no 'x' to remove the area that includes the Telefonica logo and links.  We want to add it so that the user can dismiss those if he/she wishes.
(Reporter)

Comment 1

3 years ago
This will be moving to a P2 when we streamline our bugs to use a new priority definition.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1113613#c1 if you'd like more details.
backlog: --- → Fx36+
Priority: -- → P1
(Reporter)

Comment 2

3 years ago
Moving all P1->P2.  (P2 means a major bug that we very much want to fix, but we wouldn't stop ship or block the release for it.)
(Reporter)

Comment 3

3 years ago
Here's the actual change from P1->P2 (per the previous comment).  P2 indicates a major bug, but not a stop ship.
Priority: P1 → P2
Created attachment 8540659 [details] [diff] [review]
Added close button to the "Powered by" Loop panel area.
Attachment #8540659 - Flags: review?(standard8)
Iteration: --- → 37.1
Points: --- → 1
Target Milestone: --- → mozilla37
Created attachment 8540731 [details]
Scree shot of panel with patch

The patch here doesn't feel quite right. Hence looking for input from Sevaan:

- If we click 'x' on this initial pane, then the ToS space (Powered by etc...) is removed and we end up with just a white space.

That's weird and seems a bit pointless.

- Restarting the browser then no longer shows the Get Started button. This seems to be a strange side effect when the 'x' is in the ToS section.


TBH, I'm not convinced we need an 'x' button when the Get Started is shown. I think once we're on the main view of the rooms list having an 'x' makes sense.

(I know the original mockups showed it on the get started view, but I think I'm disagreeing with those).
Attachment #8540731 - Flags: ui-review?(sfranks)
Comment on attachment 8540731 [details]
Scree shot of panel with patch

I agree, Mark. The X seems superfluous on this panel. The only action should be to click the "Get Started" button.

NI'ing Darrin and Holly since they were involved in the design of this. What was the reasoning for using the X here? Would you be okay if we removed it from this panel?
Flags: needinfo?(hhabstritt.bugzilla)
Flags: needinfo?(dhenein)
Attachment #8540731 - Flags: ui-review?(sfranks) → ui-review+
(In reply to Sevaan Franks [:sevaan] from comment #6)
> Comment on attachment 8540731 [details]
> Scree shot of panel with patch
> 
> I agree, Mark. The X seems superfluous on this panel. The only action should
> be to click the "Get Started" button.
> 
> NI'ing Darrin and Holly since they were involved in the design of this. What
> was the reasoning for using the X here? Would you be okay if we removed it
> from this panel?

When the 'x' is clicked, it shouldn't result in an empty space. The space should be removed, thus, making the panel height shorter. This sounds like a bug to me.

Mark's comment here also sounds like a bug. "- Restarting the browser then no longer shows the Get Started button. This seems to be a strange side effect when the 'x' is in the ToS section."  (needinfo'd MattN for this)


Darrin designed this, and may also need to respond, but I can share what I understand. The 'x' is more beneficial for the next state of this panel (http://cl.ly/image/1D2H1V0I3N1j) where the conversations are started and listed (though if it is present in the second panel state, it should also be in the first for consistency). The current logic is that the "Powered by Telefonica", TOS, and Privacy Notice do not go away until the first conversation has been initiated. This will stay true (though I think this is a very passive way to dismiss the contents). The 'x' allows the user to dismiss this right away, which is a more active way of acknowledging that they have seen this information and allows the user to remove some clutter from the panel, making the height of it shorter. Having a shorter height in this panel asap, will especially benefit users with small viewport sizes going through the First Time Use Experience.

I agree that the fewer choices in the "Get Started" panel, the better. With that argument, the TOS and privacy links should also be removed. If the links are present, I don't think the 'x' will add any further distraction than the links already do. Altering the display of this information and changes to the logic in the original design spec should be discussed with Romain (needinfo'd). Sounds like something to discuss for future iterations, but there may be legal reasons to make the user aware of this content at this point in the flow.
Flags: needinfo?(rtestard)
Flags: needinfo?(hhabstritt.bugzilla)
Flags: needinfo?(MattN+bmo)
Holly has pretty much summed up my thoughts on this, mainly that we wanted to allow the user an explicit way to remove that section (they are not aware of if/when it goes away).
Flags: needinfo?(dhenein)

Comment 9

3 years ago
I agree with Holly and Darrin there although obviously not a priority for Fx37 if this is actually a significant effort to implement without the bugs (white space and restarting the browser then no longer shows the Get Started button).
Flags: needinfo?(rtestard)

Comment 10

3 years ago
if it lands in 37 - great.  if not will ride trains to 38.
Assignee: nobody → nperriault
backlog: Fx36+ → Fx38+

Updated

3 years ago
Iteration: 37.1 → 38.1 - 26 Jan
Flags: needinfo?(MattN+bmo)
Comment on attachment 8540659 [details] [diff] [review]
Added close button to the "Powered by" Loop panel area.

Sorry I've been so long to get back to this. I was waiting for some of the discussion to complete.

What I think we need from the discussion is

- 'x' to hide just the ToS & Logos, not affect anything else
- Resize the panel when the ToS/Logos are removed
- 'x' to hide the ToS when in the conversation views
Attachment #8540659 - Flags: review?(standard8) → review-
(In reply to Holly Habstritt Gaal [:Habber] from comment #7)
> Mark's comment here also sounds like a bug. "- Restarting the browser then
> no longer shows the Get Started button. This seems to be a strange side
> effect when the 'x' is in the ToS section."  (needinfo'd MattN for this)
ser aware of this content at
> this point in the flow.

There was discussion about hiding the getting started button when the X is clicked as an easy way for users who are using a new profile but don't want the tour because either they already saw it on their other computer/profile or they are QE testing a new profile and just want to test non-FTU stuff and the tour just gets in their way. It may be somewhat unobvious that the X will do both though. I don't feel strongly about this.
(In reply to Matthew N. [:MattN] from comment #13)
> There was discussion about hiding the getting started button when the X is
> clicked as an easy way for users who are using a new profile but don't want
> the tour because either they already saw it on their other computer/profile

I think a second X for that section makes the most sense for the user.

> or they are QE testing a new profile and just want to test non-FTU stuff and
> the tour just gets in their way.

It doesn't feel right that we would be engineering our software to make repetitive QE testing simpler.

Comment 15

3 years ago
hi Niko - were the review comments small enough that you can make the changes or should we re-assign based on Reading work?
Flags: needinfo?(nperriault)

Updated

3 years ago
backlog: Fx38+ → backlog+
Rank: 25
Flags: firefox-backlog+
(In reply to sescalante from comment #15)
> hi Niko - were the review comments small enough that you can make the
> changes or should we re-assign based on Reading work?

The work required on this bug is not well-enough defined and not in a position where we can move forward.

Sevaan: Can you take a look through all the comments on this bug please, and then update the user story with what you think we should be doing? Thanks.
Assignee: nperriault → nobody
Iteration: 38.1 - 26 Jan → ---
Flags: needinfo?(sfranks)
Target Milestone: mozilla37 → ---
Flags: needinfo?(nperriault)
Romain,

Is there a legal requirement to have the TOS on the Conversations panel? Doesn't clicking the "Get Started" button mean they have agreed, in which case the TOS and privacy notice are redundant on the second panel?

My ideal flow:

- User opens Hello Panel and sees Get Started button and legal text.
- User accepts agreement by clicking Get Started button.
- That's it.

No need for an X at all then as it is only seen on the Get Started panel.
Flags: needinfo?(sfranks) → needinfo?(rtestard)
We originally decided to show the ToS and privacy notice until the user had his first call.
This meant that when rooms got implemented the ToS and privacy notice were displayed until the user had a first call or get into a room with someone else.

What you suggest here could not apply in case at the end of the FTU the user does not manage to get someone in the room with him - although I am not sure we should keep this behavior and maybe acknowledging the ToS and privacy notice with the "Get started" button is good enough since it's not really obvious to the user why the links disappear after someone else joins the room or after the first call occurs. 
Also when we made the decision to keep the ToS and PN links we did not have the "Get started" panel and it seems to revisit this now.

Mika, would we be OK to display the ToS and privacy notice only as part of the "Get started" panel?
By clicking "Get started" the user would acknowledge the terms.
Flags: needinfo?(rtestard) → needinfo?(udevi)

Comment 19

3 years ago
> Mika, would we be OK to display the ToS and privacy notice only as part of
> the "Get started" panel?
> By clicking "Get started" the user would acknowledge the terms.

There are two issues here: the logo and the ToS/PN.

On the first issue of the logo, have you confirmed with Susan's team if it is okay with TEF (from a partner perspective and from a contractual perspective) if the user has the option of "x"ing out of the logo?

On the second issue of the ToS/PN, the "x" option depends on a few things.  I described the legal requirements below and then tried to answer the question on whether it's okay to have an "x" next to the ToS/PN.

There are three legal requirements for the ToS and PN:
(1) The user has to be presented with the ToS and PN before FTU of the product. 
- This is currently happening by displaying it on the "Get Started" panel

(2) The user has to have a way to access the ToS & PN at any point during the product experience.  
- I'm not sure if this is currently happening for users after the "get started" panel.  
- If not, it can be corrected by adding it as options to the gear icon (which currently has "Tour, Sign In, and Help" as options.  Or perhaps you have another idea of how to ensure the user can access  these docs from inside the product experience

(3) Link clickers have to access the ToS and PN before they start the conversation
- This is currently happening b/c the ToS and PN are presented as links in the bottom of the room

Answer to your question:
(1) I'm not sure I understand the issue.  I thought the "Get Started" Panel only happens on the first time use, and after that, it does not appear.  
- If my understanding is correct, then you can't have an "x" option to get rid of the ToS and PN on the first presentation.  This makes our process of getting user consent questionable.
- If my understanding is not correct, and it is possible for the user to go through the "Get Started" panel multiple times after FTU, then it is fine to remove the ToS and PN from subsequent display.  You can either do this optionally by the "x" or by default by just removing it. However, this is only okay as long as the user can access it from inside the product.  

LMK if you have questions.
Mika
Flags: needinfo?(udevi)
(In reply to Mika from comment #19)
> > Mika, would we be OK to display the ToS and privacy notice only as part of
> > the "Get started" panel?
> > By clicking "Get started" the user would acknowledge the terms.
> 
> There are two issues here: the logo and the ToS/PN.
> 
> On the first issue of the logo, have you confirmed with Susan's team if it
> is okay with TEF (from a partner perspective and from a contractual
> perspective) if the user has the option of "x"ing out of the logo?
> 
> On the second issue of the ToS/PN, the "x" option depends on a few things. 
> I described the legal requirements below and then tried to answer the
> question on whether it's okay to have an "x" next to the ToS/PN.
> 
> There are three legal requirements for the ToS and PN:
> (1) The user has to be presented with the ToS and PN before FTU of the
> product. 
> - This is currently happening by displaying it on the "Get Started" panel
> 
> (2) The user has to have a way to access the ToS & PN at any point during
> the product experience.  
> - I'm not sure if this is currently happening for users after the "get
> started" panel.  
It gets displayed to the user in the panel until after he gets into his first call.
After that the user can access the SUMO pages through "Help" in the gear menu of the Hello panel.
The Firefox Hello SUMO pages point to https://www.mozilla.org/fr/privacy/firefox-hello/ and https://www.mozilla.org/fr/about/legal/terms/firefox-hello/

Is this enough or do you feel we should have explicit direct links in the gear menu?

> - If not, it can be corrected by adding it as options to the gear icon
> (which currently has "Tour, Sign In, and Help" as options.  Or perhaps you
> have another idea of how to ensure the user can access  these docs from
> inside the product experience
> 
> (3) Link clickers have to access the ToS and PN before they start the
> conversation
> - This is currently happening b/c the ToS and PN are presented as links in
> the bottom of the room
> 
> Answer to your question:
> (1) I'm not sure I understand the issue.  I thought the "Get Started" Panel
> only happens on the first time use, and after that, it does not appear.  
> - If my understanding is correct, then you can't have an "x" option to get
> rid of the ToS and PN on the first presentation.  This makes our process of
> getting user consent questionable.

We currently display the ToS/PN links until the first user gets into a call - i.e after the FTU, if the user did not get into a call during the FTU, we'll again display the links until the user finally gets into a call.
The question was whether we should carry on displaying the links after the FTU is completed?

> - If my understanding is not correct, and it is possible for the user to go
> through the "Get Started" panel multiple times after FTU, then it is fine to
> remove the ToS and PN from subsequent display.  You can either do this
> optionally by the "x" or by default by just removing it. However, this is
> only okay as long as the user can access it from inside the product.  
The user can't get to the get started panel again although per my comment above the ToS/PN links will still be displayed currently until you get into your first call.
The user will be able to access the ToS/PN links through the Help menu although this is what you have to do:
1 Click the gear menu
2 Click Help
3 Click on the link at the bottom of the SUMO page
4 On the new SUMO page scroll to the bottom and see the PN and ToS links
> 
> LMK if you have questions.
> Mika

My recommendation would be to show the ToS and PN links only on the "Get Started" panel but make them more discoverable through the Help menu in the first SUMO page reached from the Help menu.

Is this acceptable?

@Sevaan - I agree that we don't need an (x) here since it's only on the get started panel.

Comment 21

3 years ago
Hi Romain, 

Your suggestion is fine: to show the ToS and PN links only on the "Get Started" panel for FTU, since the links are accessible from the Help menu.  If you want to make them more discoverable, you can, but it's also okay the way it is now.  

Just to confirm, users who are link clickers will still see the ToS and PN at the bottom of their Hello screen right?

Comment 22

3 years ago
Also, did you confirm with Susan's team that it's okay w. TEF to remove the logos from the "get started" panel after FTU?
(In reply to Mika from comment #21)
> Hi Romain, 
> 
> Your suggestion is fine: to show the ToS and PN links only on the "Get
> Started" panel for FTU, since the links are accessible from the Help menu. 
> If you want to make them more discoverable, you can, but it's also okay the
> way it is now.  
> 
Great
> Just to confirm, users who are link clickers will still see the ToS and PN
> at the bottom of their Hello screen right?
They will prior to joining the conversation so they can review the terms. I pinged you a separate question on this subject on https://bugzilla.mozilla.org/show_bug.cgi?id=1138453#c1

Comment 24

3 years ago
Okay, commented on the other bug.  Can you confirm what was the outcome after speaking with Susan and TEF on the "x" for TEF branding?
Tef is OK with the proposed change.
Since the title and most of the thread is now not a good reflection of what the requirement now is (originally the bug was intended to add a way to dismiss the partner logo - which has been decided not to be required), I am closing this bug as WON'T FIX and created bug 1146312 to follow-up with the implementation of "Only display partner logo and ToS/PN links on the Get started panel".
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.