[v2.2] Investigate test_sms_with_attachments tap_capture failure

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RobertC, Assigned: viorela)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8539283 [details]
logcat.txt

test_sms_with_attachments started failing on Jenkins when trying to tap on the select button. From the screenshots it's visible that the picture was not taken which would suggest some issues with tap_capture().

The issue cannot be reproduce manually.
With automation the reproduction rate is: 4 out of 10

This might require some refactoring in the camera app.
(Reporter)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-backlog+]
(Assignee)

Updated

4 years ago
Assignee: nobody → viorela.ioia
(Assignee)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-backlog+][fxosqa-auto-s7]
(Assignee)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-backlog+][fxosqa-auto-s7] → [fxosqa-auto-from-s7][fxosqa-auto-s8]
(Assignee)

Comment 1

4 years ago
Created attachment 8549717 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27115

Adhoc run: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/591/console
The failures in the adhoc are because of Bug 1109213
Attachment #8549717 - Flags: review?(jlorenzo)
Attachment #8549717 - Flags: review?(florin.strugariu)
Comment on attachment 8549717 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27115

Let's move those lines in wait_for_capture_ready()
Attachment #8549717 - Flags: review?(florin.strugariu) → review-
Comment on attachment 8549717 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27115

Looks good. I agree with Bebe's point. Also there's a change about a selector that doesn't look related to the other parts of the fix, does it?
Attachment #8549717 - Flags: review?(jlorenzo) → review-
(Assignee)

Comment 4

4 years ago
Comment on attachment 8549717 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27115

Locator updated; I also added a comment in the PR regarding the addition of the new waits in wait_for_capture_ready()
Attachment #8549717 - Flags: review?(jlorenzo)
Attachment #8549717 - Flags: review?(florin.strugariu)
Attachment #8549717 - Flags: review-
Attachment #8549717 - Flags: review?(florin.strugariu) → review-
Comment on attachment 8549717 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27115

Clearing the review until bug 1122119 gets fixed.
Attachment #8549717 - Flags: review?(jlorenzo)
Depends on: 1122119
(Assignee)

Comment 6

4 years ago
Comment on attachment 8549717 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/27115

I updated the PR and also started a new adhoc run: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/619/HTML_Report/. There are 5 unrelated failures. 
I also left a comment in the bug.
Can you guys take a look again? Thanks!
Attachment #8549717 - Flags: review?(jlorenzo)
Attachment #8549717 - Flags: review?(florin.strugariu)
Attachment #8549717 - Flags: review-
Attachment #8549717 - Flags: review?(florin.strugariu) → review+
Merge in master at: https://github.com/mozilla-b2g/gaia/commit/06b165123950df104de85caab9678414cc41d064
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.