Closed Bug 11137 Opened 21 years ago Closed 21 years ago

When menus dropped down, they stay down when other menus active

Categories

(Core :: XUL, defect, P3, major)

defect

Tracking

()

VERIFIED DUPLICATE of bug 11266

People

(Reporter: cpratt, Assigned: hyatt)

Details

Build ID: 1999070208 (Win32; Linux used 070212 build)
Platform: Windows NT, Linux; Mac OS presumably the same

To reproduce:
- Launch apprunner
- Click on the QA (or other) menu to drop it down
- Click on the Shopping menu to drop it down

Result: Both menus are displayed.

Expected result: When the Shopping menu is drawn, the QA menu should go away.
Severity: normal → major
Also, the menu doesn't go away when someone clicks somewhere outside of it,
which it should.

To reproduce:
1. Click "Go" so that that menu drop down.
2. Without moving the pointer over another menu, move it to the URL field.
3. Click in the field and write some letters.

What happens:
The Go-menu stays up and the letters go into the url-field.

What Should Happen:
The Menu(s) should go away and the letters go into the url-field.

CCing Hyatt since he's been working at the menus lately.
Assignee: don → hyatt
Component: XPApps → XP Toolkit/Widgets
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 11266 ***
Status: RESOLVED → VERIFIED
Marking verified duplicate (of a bug filed later than this one, but hey).
You need to log in before you can comment on or make changes to this bug.