Update error page for sslv3 to rely on a more specific error than no_cypher_overlap

VERIFIED FIXED in Firefox 36

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Gijs, Assigned: emk)

Tracking

unspecified
Firefox 37
Points:
5
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite -
qe-verify +

Firefox Tracking Flags

(firefox36 verified, firefox37 verified, firefox38 verified)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1098371 +++
Duplicate of this bug: 1109859
Flags: firefox-backlog+
Apply this on top of the patch from bug 1098371.
The sslv3 error page will not be displayed on m-c without this patch.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Attachment #8546624 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8546624 [details] [diff] [review]
Use SSL_ERROR_UNSUPPORTED_VERSION for SSLv3 error page

Review of attachment 8546624 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me - thanks for the patch!

Note there might be slight bitrot because of the removal of the trailing whitespace as per the review nits. I already landed bug 1098371 on fx-team, so landing this on there is probably easiest. I can do that if you don't have an fx-team tree to hand.
Attachment #8546624 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs Kruitbosch from comment #3)
> Note there might be slight bitrot because of the removal of the trailing
> whitespace as per the review nits. I already landed bug 1098371 on fx-team,
> so landing this on there is probably easiest. I can do that if you don't
> have an fx-team tree to hand.

OK, please. (I'm usually working on mozilla-inbound, so I have no fx-team tree to hand.)
Keywords: leave-open
remote:   https://hg.mozilla.org/integration/fx-team/rev/d5977152c82a
Flags: qe-verify+
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/d5977152c82a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Iteration: --- → 37.3 - 12 Jan
Depends on: 1084986
Verified fixed on Nightly 38.0a1 (2015-01-22) and Aurora 37.0a2 (2015-01-22), using Ubuntu 12.04 32 bit, Windows 7 64 bit and Mac OS X 10.9.5 with https://sslv3.dshield.org/ as a test page. The updated neterror page now states 'ssl_error_unsupported_version'.
Status: RESOLVED → VERIFIED
Uplifted to beta per the approvals in bug 1098371:

https://hg.mozilla.org/releases/mozilla-beta/rev/ea3b10634381
Verified fixed on Firefox 36 RC build 2 (BuildID=20150222232811), using Ubuntu 14.04 64 bit, Windows 7 64 bit and Mac OS X 10.10 with: https://contact.russlavbank.com/ and https://sslv3.dshield.org/ ("security.tls.version.fallback-limit" set to 3 as mentioned in bug 1098371). The updated neterror page displays with error 'ssl_error_unsupported_version' as expected.
You need to log in before you can comment on or make changes to this bug.