Page break should be forced before floating image

REOPENED
Unassigned

Status

()

Core
Printing: Output
P3
normal
REOPENED
16 years ago
8 years ago

People

(Reporter: Koike Kazuhiko, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Page break should be forced before floating image if it is located
near the end of the page.

Now the part of floating image goes out of page.

Updated

16 years ago
Summary: Page break should be forced before floating image → Page break should be forced before floating image

Comment 1

16 years ago
I need a testcase

Comment 2

16 years ago
Koike, please provide a testcase.
(Reporter)

Comment 3

16 years ago
Created attachment 59279 [details]
Image file for testcase
(Reporter)

Comment 4

16 years ago
Created attachment 59281 [details]
Testcase

Updated

16 years ago
Target Milestone: --- → mozilla1.1

Updated

15 years ago
Keywords: testcase
Target Milestone: mozilla1.1alpha → ---
-> jkeiser
Assignee: dcone → jkeiser
Priority: -- → P3
Target Milestone: --- → Future

Comment 6

14 years ago
Still breaking float elements in Mozilla 1.6

That should be fixed, CSS 2 is here since 1999, and mozilla is saying it is
standard compliant.
(http://www.w3.org/TR/1998/REC-CSS2-19980512/page.html#q16)

Updated

10 years ago
Assignee: john → nobody
QA Contact: sujay → printing

Comment 7

9 years ago
I tried attachment 59281 [details] and cannot reproduce with recent trunk/Linux.
This problem seems to be fixed.
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 8

9 years ago
(In reply to comment #7)
> I tried attachment 59281 [details] and cannot reproduce with recent trunk/Linux.
> This problem seems to be fixed.
> Marking WFM.
 
I'm sorry.
That comment is wrong.
This problem is still reproducible.
Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

8 years ago
Still breaks floated elements near the bottom of the page in 3.5.
You need to log in before you can comment on or make changes to this bug.