Video playback really chunky with MSE

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
P1
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8539618 [details]
Screen Shot 2014-12-19 at 8.43.31 PM.png

This is with the latest Nightly on OSX 10.10.1.  The video URL Is <https://www.youtube.com/watch?v=M6RfU9eVaFE>.  This video stopped and restarted after a while several times.  I also noticed the video jumping back to a few seconds earlier (perhaps 2-3s) a few times during the playback.  I will attach before and after screenshots from stats for nerds.
(Reporter)

Comment 1

4 years ago
Created attachment 8539619 [details]
Screen Shot 2014-12-19 at 8.42.52 PM.png
Ehsan - Can you paste in your about:support?
Flags: needinfo?(ehsan.akhgari)
(Reporter)

Comment 3

4 years ago
Created attachment 8540141 [details]
about:support
Flags: needinfo?(ehsan.akhgari)
Priority: -- → P1
I'm not sure at what point of the video the issues were occurring, but I can't reproduce any problems with the first 3 minutes of video. My guess is that this was fixed by the flurry of fixes over the past few weeks.

Ehsan, can you reproduce in today's Nightly?
Flags: needinfo?(ehsan)
(Reporter)

Comment 5

3 years ago
(In reply to Bobby Holley (Busy with media, don't ask for DOM/JS/XPConnect things) from comment #4)
> I'm not sure at what point of the video the issues were occurring, but I
> can't reproduce any problems with the first 3 minutes of video. My guess is
> that this was fixed by the flurry of fixes over the past few weeks.

Could be, yes.

> Ehsan, can you reproduce in today's Nightly?

No but I can never reproduce these issues reliably.  What I can say for sure according to my experience on YouTube is that video playback in newer nightlies works a lot better than it used to.

If you don't think this is actionable please feel free to close it.
Flags: needinfo?(ehsan)
OK. Thanks Ehsan.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.