Closed Bug 1114370 Opened 7 years ago Closed 6 years ago

mozonfullscreenerror does not fire

Categories

(Core :: DOM: Events, defect)

37 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: crosbow, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141221030204

Steps to reproduce:

document.addEventListener('mozfullscreenerror', function(e){console.log(e)});


Actual results:

nothing


Expected results:

log event info
Could you attach a minimal test case?
Flags: needinfo?(crosbow)
Attached file FullcreenAPI.html
Status: UNCONFIRMED → NEW
Component: DOM: Events → Toolbars and Customization
Depends on: 729011
Ever confirmed: true
Flags: needinfo?(crosbow)
OS: Linux → All
Product: Core → Firefox
Version: 37 Branch → Trunk
Blocks: 545812
sorry, wrong bug.
No longer blocks: 545812
Component: Toolbars and Customization → DOM: Events
No longer depends on: 729011
Product: Firefox → Core
Version: Trunk → 37 Branch
Could you attach a minimal test case?
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(crosbow)
Flags: needinfo?(crosbow)
WFM, set full-screen-api.enabled = false so that fullscreen fails
In the past, denying fullscreen won't trigger "fullscreenerror" because we enter fullscreen before we prompt to ask user for permission. The "fullscreenerror" event is fired only if the request violates any restriction, or the user permanently denies your website from requesting fullscreen.

Now, we no longer ask user for permission for fullscreen, and thus we would never fire this event because of user action.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.