Closed Bug 1114499 Opened 6 years ago Closed 6 years ago

crash in java.lang.NullPointerException: at org.mozilla.gecko.menu.MenuPopup.showAsDropDown(MenuPopup.java)

Categories

(Firefox for Android :: General, defect)

38 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 38
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- unaffected
firefox38 --- affected
fennec 38+ ---

People

(Reporter: TeoVermesan, Assigned: fedepaol)

References

Details

(Keywords: crash, reproducible)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-c15b2a76-88b2-4d69-bcdf-a6cd82141222.
=============================================================

Steps to reproduce:
1. Open Firefox
2. Tap the tab counter button from the top right corner to open Tab Tray
3. Press the 'three-dots-menu' 

Expected results:
- A dialog opens with the following options "New Private Tab" and "Close all Tabs"

Actual results:
- Firefox crashes
Regression window:
1.mozilla-central
19-12 good build
20-12 bad build
pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1427b365cd39&tochange=490f124d7dea

2.inbound
1419033618 good build
1419044713 bad build
pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2e09c000bb8b&tochange=490f124d7dea
My bet is a bad merge / conflict resolve and I'll need to restore this
https://hg.mozilla.org/mozilla-central/rev/93840f9b5af8#l8.84

Will post a patch this evening if everything works fine. Sorry for the regression :(
The patch for bug 909434 was backed out.
This is still an issue.

I believe the problem line in the patch that landed on 1/29 in bug 909434 is [1]:

-            mPopupMenu.setAnchor(mMenuButton);

NI Federico to work on a patch.

[1]: https://hg.mozilla.org/mozilla-central/diff/83f7e0e9ea72/mobile/android/base/tabs/TabsPanel.java#l1.84
Assignee: nobody → fedepaol
Flags: needinfo?(fedepaol)
Assuming this doesn't affect 37, but we should test just in case.
Attached patch bug-1114499-fixSplinter Review
Here we go, I don't think it affects 37 since wes pushed this a couple of days ago.
Flags: needinfo?(fedepaol)
Attachment #8557412 - Flags: review?(michael.l.comella)
I reproduce this crash on latest Nightly (2015-02-01) using Alcatel One Touch (Android 4.1.2) but I cannot reproduce on latest Aurora 37 (2015-02-01)
I get this by attempting to open the dotted menu when the tab drawer is open (Nightly 02/02).
tracking-fennec: --- → ?
Keywords: reproducible
Comment on attachment 8557412 [details] [diff] [review]
bug-1114499-fix

Review of attachment 8557412 [details] [diff] [review]:
-----------------------------------------------------------------

Unfamiliar with the larger code changes from bug 909434, but r+ on the basis of adding the removed line.
Attachment #8557412 - Flags: review?(michael.l.comella) → review+
Status: NEW → ASSIGNED
Keywords: checkin-needed
Version: Firefox 37 → Firefox 38
hi, can we get a try run for this change ? thanks!
Flags: needinfo?(fedepaol)
Keywords: checkin-needed
Sorry, I don't have the rights to push / run on try.
Can somebody else do that for us?
Flags: needinfo?(fedepaol) → needinfo?(wjohnston)
Federico, I pushed the patch to try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=97b57b67dbaa
I assumed only the Robocop tests needed to be run, since this is a Java only change.
https://hg.mozilla.org/mozilla-central/rev/788a0bb0ce16
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
Thanks for the fix, Federico!
A dialog opens with the following options "New Private Tab" and "Close all Tabs" while in normal tab tray and "New Tab" and "Close Private Tabs" in private tabs tray on latest Firefox for Android 38.0a1 (2015-02-05) using Nexus 4 (Android 4.4.)
tracking-fennec: ? → 38+
You need to log in before you can comment on or make changes to this bug.