2.5% tp5 rss + Canvasmark OSX 10.6 regression on inbound (v.37) Dec 19 from push e7b95eb855a2

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: jmaher, Assigned: mstange)

Tracking

({perf, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

3 years ago
Here is a graph showing the regression:
http://graphs.mozilla.org/graph.html#tests=%5B%5B289,63,21%5D%5D&sel=1418966907545.5125,1419011185748.5076,4913.793103448275,6724.137931034483&displayrange=7&datatype=running

I did some retriggers on tbpl:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&fromchange=e4bee2367e67&tochange=a736be6898d4&jobname=Rev4%20MacOSX%20Snow%20Leopard%2010.6%20mozilla-inbound%20talos%20chromez


Canvasmark for 10.6 was posting normally between 6000 and 6200, this is the revisions where we dropped below 6000 as our score, in many data points below 5900.
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=e7b95eb855a2

Canvasmark is run in the 'chromez' job on tbpl.
(Reporter)

Comment 1

3 years ago
this also is the cause of a 10% osx 10.6 tp5 rss main regression:
http://graphs.mozilla.org/graph.html#tests=%5B%5B261,%2063,%2021%5D,%20%5B261,%2064,%2021%5D%5D&datatype=running&sel=1418938403000,1419111203000
(Reporter)

Updated

3 years ago
Summary: 2.5% Canvasmark OSX 10.6 regression on inbound (v.37) Dec 19 from push e7b95eb855a2 → 2.5% tp5 rss + Canvasmark OSX 10.6 regression on inbound (v.37) Dec 19 from push e7b95eb855a2
So, I would expect the slowdown from switching to tiling, and it would be good for Markus to confirm that this slowdown is expected, explainable and acceptable.  Markus is on PTO until January 5th, so we may miss the "deal with this in 3 days" - is that OK in this case?
(Reporter)

Comment 3

3 years ago
Thanks Milan.  Yeah, PTO makes it hard to follow up.  As long as we can agree this is reasonably expected that would be great.  We can wait for Markus as well.  Does the 10.5% increase in RSS make sense from what changes went in?
(Assignee)

Comment 4

3 years ago
The canvasmark regression is not expected and I don't have an explanation yet.
The rss main regression is something we also saw in the try pushes, but we decided to just accept it for now because it's not very actionable. We should look into tiling memory usage again once we've tweaked tile sizes an tile cache heuristics.
(Assignee)

Comment 5

3 years ago
Assigning to myself so I'll remember to look at canvasmark profiles once my talos profiling work is in place.
Assignee: nobody → mstange
(Reporter)

Comment 6

3 years ago
this is on mozilla-aurora now that we uplifted.  after turning off tp5, we still have canvasmark running on 10.6.
(Reporter)

Comment 7

3 years ago
this is now on mozilla-beta.
(Assignee)

Comment 8

3 years ago
Try pushes with profiling:
tiling off: https://treeherder.mozilla.org/#/jobs?repo=try&revision=39cec82904f4
tiling on : https://treeherder.mozilla.org/#/jobs?repo=try&revision=99749de91993
(Assignee)

Comment 9

3 years ago
The tcanvasmark profiles don't show anything interesting tiling-related. They only show that we're spending a lot of time blocking on the sync transaction, which is bug 1126954. Fixing that will have more impact on that test than fixing anything tiling-related.

I'm going to call this WONTFIX for now, because I don't know what to do about it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.