[Flame][Clock]An alarm will be added automatically when you check/uncheck alarm.

RESOLVED DUPLICATE of bug 1080295

Status

defect
RESOLVED DUPLICATE of bug 1080295
5 years ago
4 years ago

People

(Reporter: liuke, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

Attachments

(3 attachments)

Posted file logcat_1627.txt
[1.Description]:
[FlameV2.2][Clock]An alarm will be added automatically when you check/uncheck alarm in Clock.
Found time:16:27
See attachment:1627.mp4 and logcat_1627.txt

[2.Testing Steps]: 
1.Launch Clock.
2.Add three alarm.
3.Tap an alarm, then delete it.
4.Delete other alarm.
5.Check/Uncheck an alarm.

[3.Expected Result]: 
4.The alarm should be delete successfully.
5.Alarm should not be added automatically.

[4.Actual Result]: 
4.You can't delete the alarm successfully.
5.Device will add an alarm automatically.

[5.Reproduction build]: 
Gaia-Rev        ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/b915a50bc6be
Build-ID        20141222040204
Version         37.0a1

[6.Reproduction Frequency]: 
Once,1/5
TCID: Free Test
Reporter

Comment 1

5 years ago
Posted video 1627.MP4
Hi Teri, Could you help to check this, I cannot reproduce it, but it looks buggy from the video, thanks.
Flags: needinfo?(twen)

Comment 3

5 years ago
I cannot reproduce this. Followed the steps above, I can delete alarms without problem.
Flags: needinfo?(twen)
Hi Lance, Could you help to try again with adb logcat gaia log, thanks...
Flags: needinfo?(liuke)
Reporter

Comment 5

5 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #4)
> Hi Lance, Could you help to try again with adb logcat gaia log, thanks...

Hi Eric,
    I have reproduced this issue on latest Flame 2.2.


Step:
1. Launch Clock.
2. Tap create new alarm icon for more than 3 times continuously.
3. Delete some alarms until two alarm remains.
4. Check/Uncheck one of the alarms.
5. Delete the alarm.

[3.Expected Result]: 
4.Alarm should not be added automatically.
5.The alarm should be delete successfully.

[4.Actual Result]: 
4.Device will add an alarm automatically.
5.You can't delete the alarm successfully.

Note: If you long press Home key to kill the clock process, the issue will disappear.

Fail rate: 3/5
Found time:17:07
See attachment: 1707.mp4 and logcat_1707.txt
Flags: needinfo?(liuke) → needinfo?(echang)
Reporter

Comment 6

5 years ago
Posted file logcat_1707.txt
Hi Mike, I cannot reproduce this, but is there any clue from log, thanks..
Flags: needinfo?(echang) → needinfo?(m)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(m)
Resolution: --- → DUPLICATE
Duplicate of bug: 1080295
You need to log in before you can comment on or make changes to this bug.