Closed Bug 1114950 Opened 8 years ago Closed 8 years ago

"ColorfulTabs" add-on does not work with e10s

Categories

(Firefox :: Extension Compatibility, defect)

37 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
e10s + ---

People

(Reporter: bullionareboy, Unassigned)

References

()

Details

Attachments

(1 file)

Almost all the options and tweaks of ColorfulTabs add-on works, but it does not confirm to the new Australis look of the browser.
The Underline of the e10s mode is white in color instead of the default black

Its goes back to box shaped tabs.
Blocks: e10s-addons
Binary Turf, are you the developer of the "ColorfulTabs" add-on? The add-on seems to be broken with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org or ask Ally on this bug. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox

https://addons.mozilla.org/en-US/firefox/addon/colorfultabs/
Please attach screenshot. How does it work with the non-e10s?
Flags: needinfo?(bullionareboy)
As I've mentioned the add-on works fine, except that it does not confirm to the australis look which Firefox has adopted. The add-on makes use of box tabs.

Also the underline is white, its black as default on e10s without the addon.
Flags: needinfo?(bullionareboy)
It has more to do with using the persona theme than anything to do with e10 at all.

1) When reporting bugs please make sure you report them https://www.binaryturf.com/forums because that's where I provide support.
2) I do not consider compatibility issues with third-party addons necessarily as bugs. Two addons trying to style the tabs will break something.
Binary Turf forgive my knowledge and my misunderstanding that the box tab look was related to e10s
Assignee: Jim Mathies
Link to add-on:
https://addons.mozilla.org/en-US/firefox/addon/colorfultabs/
https://www.binaryturf.com/forum/colorfultabs
Contact info for add-on: ?
Add-on ID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
How well does it work?: 100%
Steps to reproduce working features:
- use of tab context menu to set color
- options panel has various tweaks, all appear to generaqlly work.
- no cpow spam in the console
Any obvious performance problems? none
Chromium version: couldn't find it
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
type: xul
This add-on is actually only partially compatible with e10s in its current state. The basic color generation functionality works appropriately, but the "Generate Colors by Domain Hostname" option fails with e10s enabled.

Tested on Firefox Beta 50 and Firefox Dev 51 with identical behavior in both versions.
You need to log in before you can comment on or make changes to this bug.