Rename and deletion of the created Rooms is not properly updated when registering in two devices with the same identity

VERIFIED FIXED

Status

Firefox OS
Gaia::Loop
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: oteo, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Room1.1.1_TestRun1][tef-triage])

Attachments

(1 attachment)

61 bytes, text/x-github-pull-request
borjasalguero
: review+
oteo
: feedback+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
Reproduced with master Loop client (future 1.1.1 release) and latest 2.0 FxOS version

Pre-requisites: Device A and Device B have master Loop version istalled and are registered in the application with the same identity.

STR:
1. Device A creates a Room1, once is created Room1 is properly updated in the Room list of Device B
2. Device A renames Room1, the new name is Room2
3. Device A deletes Room2

Actual Result: 
2. Room1 is renamed to Room2 in Device A. 
In Device B nothing happens, push is received but in its Room List, Room1 is NOT renamed to Room2
3. Room2 is removed in Device A. 
In device B, the Room1 is still there

Expected Result: 
2. Room1 is renamed to Room2 in Device A and Device B
3. Room2 is removed in Device A and Device B

In both situations 2. and 3. the same error is happening in the BBDD of the Loop Mobile Client

E/GeckoConsole( 6654): [JavaScript Error: "ConstraintError" {file: "app://loop.services.mozilla.com/js/helpers/database_helper.js" line: 201}]
E/GeckoConsole( 6654): Content JS ERROR at app://loop.services.mozilla.com/js/screens/calllog.js:1055 in _addRoom/<: ERROR when storing the room [object Event]
(Reporter)

Updated

4 years ago
Blocks: 1097722, 1097710
(Reporter)

Updated

4 years ago
Summary: Rename and deletion of the created Rooms is not properly updated when registering in two devices with the same identity, → Rename and deletion of the created Rooms is not properly updated when registering in two devices with the same identity
(Assignee)

Comment 1

4 years ago
I am not able to reproduce this bug currently. My devices are Flame and Fire E. Could you confirm if this issue is still reproducible?
Flags: needinfo?(oteo)
(Reporter)

Comment 2

4 years ago
Now, I am not able to reproduce it although this morning I was able to see it testing in another branch. That's the reason I would like Isabel and Loli to test it to ensure if there could be a corner case or other STR that could be failing.

Thanks a lot!
Flags: needinfo?(oteo)
Flags: needinfo?(lolimartinezcr)
Flags: needinfo?(isabelrios)
(Reporter)

Comment 3

4 years ago
After some testing today, I continue seeing the issue, although it seems a race condition as it does not always happen, we should investigate more to try to fix it.

Comment 4

4 years ago
Removing ni, as Maria said, sometimes it is still possible to see the problem.
Flags: needinfo?(isabelrios)

Updated

4 years ago
Blocks: 1098582
QA Whiteboard: [TEF-Track]
Flags: needinfo?(lolimartinezcr)

Updated

4 years ago
Whiteboard: [Room1.1.1_TestRun1]
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
Created attachment 8548769 [details] [review]
Github pull request

Hi gals, I need your support here. Investigating into code I realized that we could have collisions between synchronizations and this patch avoids this scenario. To be honest, I wasn't able to reproduce this so please could you help me trying to reproduce the issue with my patch in order to know if it has been fixed. Thanks in advance
Attachment #8548769 - Flags: feedback?(oteo)
Attachment #8548769 - Flags: feedback?(lolimartinezcr)
(Reporter)

Comment 6

4 years ago
Comment on attachment 8548769 [details] [review]
Github pull request

After some testing, I've not been able to reproduce the bug with Cristian's branch.

Setting ni to Isabel to verify it, as she also saw the issue some time ago.
Flags: needinfo?(isabelrios)
Attachment #8548769 - Flags: feedback?(oteo) → feedback+

Updated

4 years ago
QA Whiteboard: [TEF-Track]
(Assignee)

Comment 7

4 years ago
Please I need the feedback here to continue with this work, thanks a lot

Comment 8

4 years ago
Hi Cristian,

I have not forgotten, but could not check it yet. I will try to check it within today.

Comment 9

4 years ago
With Cristian's patch, after several tests creating, renaming and deleting rooms in one device and checking the room list in the other, everything seems to be working fine. Cannot reproduce the problem.
Thanks!
Flags: needinfo?(isabelrios)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8548769 [details] [review]
Github pull request

Seems it is working fine according to the feedback provided by Loli and M. Angeles. Thanks gals for your support!!!
Attachment #8548769 - Flags: review?(borja.bugzilla)
(Reporter)

Updated

4 years ago
Severity: normal → critical
Whiteboard: [Room1.1.1_TestRun1] → [Room1.1.1_TestRun1][tef-triage]
Attachment #8548769 - Flags: review?(borja.bugzilla)
Attachment #8548769 - Flags: review+
Attachment #8548769 - Flags: feedback?(lolimartinezcr)
(Assignee)

Comment 11

4 years ago
master:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/88fabf863e512e3ae8d81252a27b38c87defacaa
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 12

4 years ago
Not able to reproduce this anymore. 
Verified:
Fire E
Loop 1.1.1/d4d6d37
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.