Closed Bug 1115013 Opened 8 years ago Closed 8 years ago

b2g connects to reddit.com instead of reddit.com/.compact

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: giammyjet, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [mobile-compat-form])

Site: http://www.reddit.com
b2g connects to reddit.com instead of reddit.com/.compact

:: Steps To Reproduce

1. open b2g browser
2. search "reddit.com"

:: Expected Result

desktop webpage is shown

:: Actual Result

 mobile webpage is shown

:: Additional Information

Software Version: 2.0.0.0-prerelease
Device Information: Mozila Flame
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
typo:

:: Expected Result

mobile webpage is shown

:: Actual Result

desktop webpage is shown
It does ask at the top "looks like you're browsing on a small screen. Would you like to try reddit's mobile interface?". Does it redirect you automatically on some other mobile browsers?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(giammyjet)
The same is happening when I'm connecting to reddit.com with iOS 7. 
So I don't think there is anything wrong. It seems it's a design choice from reddit.

Is there a mobile device where the behavior is different?
If there isn't, we can close this and leave reddit to make their UI choices :)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.