Firefox 30.0 was unable to find/install an update

RESOLVED DUPLICATE of bug 394984

Status

Release Engineering
Release Requests
RESOLVED DUPLICATE of bug 394984
4 years ago
4 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
The receptionist computer (27" iMac with OS X Mavericks) had Firefox 30.0 installed and was unable to find an update this morning. Whenever she would open the About dialog it would not check for updates.

Here is what I was able to capture in her update log:
> AUS:SVC Checker:onLoad - request completed downloading document
> AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/30.0/20140605174243/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/release/Darwin%2013.3.0/default/default/update.xml
> AUS:SVC Checker:onLoad - number of updates available: 1
> AUS:SVC gCanApplyUpdates - testing write access /Applications/Firefox.app/Contents/MacOS/update.test
> AUS:SVC gCanApplyUpdates - unable to apply updates. Exception: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.create]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/components/nsUpdateService.js :: testWriteAccess :: line 328"  data: no]
> AUS:SVC UpdateService:_selectAndInstallUpdate - the user is unable to apply updates... prompting
> AUS:SVC Checker: checkForUpdates, force: true
> AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/30.0/20140605174243/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/release/Darwin%2013.3.0/default/default/update.xml?force=1
> AUS:SVC Checker:checkForUpdates - sending request to: https://aus3.mozilla.org/update/3/Firefox/30.0/20140605174243/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/release/Darwin%2013.3.0/default/default/update.xml?force=1

I managed to get her Firefox updated by doing a pave-over install with the latest Firefox version (34.0.5) but I figured I file this bug anyway just in case there's something worth investigating.
This looks like it may have been bug 394984? Updates were certainly offered, the user just couldn't apply them for some reason.
Flags: needinfo?(robert.strong.bugs)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394984
Flags: needinfo?(robert.strong.bugs)
You need to log in before you can comment on or make changes to this bug.