Closed Bug 1115150 Opened 5 years ago Closed 5 years ago

[Homescreen][RTL] Homescreen setting menu text is not right-aligned

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S4 (23jan)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: jlee, Assigned: nefzaoui)

References

Details

Attachments

(4 files)

Attached image homescreensettings
Description:
With RTL/Arabic enabled, the Homescreen setting menu text is not right-aligned. "Homescreen Settings", "Change Wallpaper", and "Add Smart Collections" text remain left-aligned.
   
Repro Steps:

*Change language setting to Arabic (RTL).

1) Update a Flame device to BuildID: 20141223010202
On Homescreen, long press on open area
Notice alignment of Homescreen settings menu text
  
Actual:
Homescreen setting menu text is left-aligned (RTL enabled).
  
Expected: 
Homescreen setting menu text is right-aligned (RTL enabled).
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
  
Repro frequency: 4/4, 100%
See attached: screenshot (homescreensettings.PNG)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
Comment on attachment 8547195 [details] [review]
[PullReq] anefzaoui:bug-1119602 to mozilla-b2g:master

Please review?
Thanks:)
Attachment #8547195 - Flags: review?(chrislord.net)
Comment on attachment 8547195 [details] [review]
[PullReq] anefzaoui:bug-1119602 to mozilla-b2g:master

Argh sorry, I thought I r+'d this days ago :/
Attachment #8547195 - Flags: review?(chrislord.net) → review+
Thanks!
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27299

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Keywords: verifyme
This issue still exist on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate  5/5

Description:The Homescreen setting menu text is still Left-aligned 
Refer to Attchment:VIDEO0251.mp4 and logcat.txt
Repro Steps:
1.Change synstem langua to Arabic 
2.Return to Home
3.Long press on open area to bring up  Homescreen setting menu

Actual behavior:Homescreen setting menu text is Left-aligned 
Expected behavior: Homescreen setting menu text is right-aligned
Status: RESOLVED → REOPENED
Flags: needinfo?(bug.autolander)
Keywords: verifyme
Resolution: FIXED → ---
Attached video VIDEO0251.mp4
Attached file logcat.txt
Needs uplift to 2.2
Flags: needinfo?(bug.autolander) → needinfo?(fabien)
@Elie: please make sure that patches on master have actually landed on 2.2 before reopening a bug for 2.2. We are seeing a few cases where bugs are reopened, but it's just a matter of uplifting the patch from master to 2.2. Please take into account for next time as this creates too much noise otherwise. Thanks!
@Josh: can you make sure to communicate this out to Marigold testers please?
Flags: needinfo?(jocheng)
Hi Elie,
Please take causion
feature-b2g: --- → 2.2+
Flags: needinfo?(jocheng)
Priority: -- → P1
Hi Elie,
Please take special caution about comment 11 from Delphine. You need to check any Git commit message in comment to mark correct "tracking-b2g" flag before perform any bug work. In situation like this bug already fix in master, you should raise question to Delphine or me about whether to fix this in 2.2 since we are targeting to launch RTL in 2.2. 
Thanks
Flags: needinfo?(zikui.yang)
(In reply to Josh Cheng [:josh] from comment #13)
> Hi Elie,
> Please take special caution about comment 11 from Delphine. You need to
> check any Git commit message in comment to mark correct "tracking-b2g" flag
> before perform any bug work. In situation like this bug already fix in
> master, you should raise question to Delphine or me about whether to fix
> this in 2.2 since we are targeting to launch RTL in 2.2. 
> Thanks

OK ,Thanks for your reminding .
Flags: needinfo?(zikui.yang)
Its landed on master
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Please request uplift approval here.
Comment on attachment 8547195 [details] [review]
[PullReq] anefzaoui:bug-1119602 to mozilla-b2g:master

[Approval Request Comment]
[User impact] if declined: incorrect icon alignment in the Homescreen for RTL users
[Testing completed]: manual, latest Gecko & Gaia
[Risk to taking this patch] (and alternatives if risky): none — this is a one-liner CSS change
[String changes made]: none.
Flags: needinfo?(fabien)
Attachment #8547195 - Flags: approval-gaia-v2.2?(doliver)
Attachment #8547195 - Flags: approval-gaia-v2.2?(doliver) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/f3a6f3be132b80bde10d5d0ceae08243ac5fb7ba
Assignee: nobody → nefzaoui
Target Milestone: --- → 2.2 S4 (23jan)
This issue is verified fixed on Flame 2.2 and Master.

Result: The homescreen action menu is right-aligned in Arabic.
 
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame Master (319mb, full flash)
Build ID: 20150202010229
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: 940118b1adcd
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.