[Settings][RTL] Wallpaper menu icons are not right-aligned

RESOLVED DUPLICATE of bug 1115152

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1115152
3 years ago
3 years ago

People

(Reporter: Jeremiah Lee, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8540954 [details]
wallpapersettings

Description:
With LTR/Arabic enabled, when viewing Wallpaper settings the menu icons are not right-aligned. Text is on right, but icons remain left-aligned.
   
Repro Steps:

*Change language setting to Arabic (RTL).

1) Update a Flame device to BuildID: 20141223010202
On Homescreen, long press open area > Tap second option "Change Wallpaper"
Notice icon alignment
  
Actual:
Icons on Change Wallpaper screen are not right-aligned when RTL/Arabic is enabled.
  
Expected: 
Icons on Change Wallpaper screen are right-aligned when RTL/Arabic is enabled.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
  
Repro frequency: 4/4, 100%
See attached: screenshot (wallpapersettings.PNG)
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(dharris)
This appears to be happening in multiple areas of the phone. Seems like a dupe of bug 1115152
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
Resolution: --- → DUPLICATE
Duplicate of bug: 1115152
You need to log in before you can comment on or make changes to this bug.